external toolchain: slightly optimize the copy of the toolchain sysroot
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 2 Oct 2011 19:20:09 +0000 (21:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 9 Oct 2011 19:24:58 +0000 (21:24 +0200)
The sysroot of an ARM CodeSourcery toolchain takes about 1.4 GB of
space, but 1.1+ GB of this space consists in locale-related
information which Buildroot doesn't use. By skipping the copy of those
unused files, we save quite a bit of time while importing the
toolchain sysroot.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk

index 4d90d15ecb5e3873b545c8a6b93a40d948da5c91..7f3efaa40dd1218938cdd30893c84caf736cf3b0 100644 (file)
@@ -79,6 +79,9 @@ copy_toolchain_lib_root = \
 #    non-default architecture variant is used. Without this, the
 #    compiler fails to find libraries and headers.
 #
+# Note that the 'locale' directories are not copied. They are huge
+# (400+MB) in CodeSourcery toolchains, and they are not really useful.
+#
 # $1: main sysroot directory of the toolchain
 # $2: arch specific sysroot directory of the toolchain
 # $3: arch specific subdirectory in the sysroot
@@ -89,7 +92,7 @@ copy_toolchain_sysroot = \
        ARCH_SUBDIR="$(strip $3)"; \
        for i in etc lib sbin usr ; do \
                if [ -d $${ARCH_SYSROOT_DIR}/$$i ] ; then \
-                       cp -a $${ARCH_SYSROOT_DIR}/$$i $(STAGING_DIR)/ ; \
+                       rsync -au --exclude 'usr/lib/locale' $${ARCH_SYSROOT_DIR}/$$i $(STAGING_DIR)/ ; \
                fi ; \
        done ; \
        if [ `readlink -f $${SYSROOT_DIR}` != `readlink -f $${ARCH_SYSROOT_DIR}` ] ; then \