enchant: New package for enchant spell-checking library.
authorWill Newton <will.newton@gmail.com>
Mon, 29 Jun 2009 10:26:23 +0000 (11:26 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 5 Jul 2009 19:29:28 +0000 (21:29 +0200)
Enchant is a spell checking library that provides a consistent API across
a number of spell-checking system backends.

Signed-off-by: Will Newton <will.newton@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/enchant/Config.in [new file with mode: 0644]
package/enchant/enchant.mk [new file with mode: 0644]

index 1dfdb203c27aa6c5e7f2ddfdf43992a407b76fc9..cb83563119547e7226f3524959f8886924cba353 100644 (file)
@@ -61,6 +61,7 @@ source "package/customize/Config.in"
 if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
 source "package/dash/Config.in"
 endif
+source "package/enchant/Config.in"
 source "package/file/Config.in"
 source "package/gamin/Config.in"
 source "package/icu/Config.in"
diff --git a/package/enchant/Config.in b/package/enchant/Config.in
new file mode 100644 (file)
index 0000000..0771a47
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_ENCHANT
+       bool "enchant"
+       help
+         Enchant is a spell-checking library that provides a consistent
+         API across a number of spell-checking system backends.
+
+         http://www.abisource.com/projects/enchant/
diff --git a/package/enchant/enchant.mk b/package/enchant/enchant.mk
new file mode 100644 (file)
index 0000000..d972465
--- /dev/null
@@ -0,0 +1,14 @@
+#############################################################
+#
+# enchant
+#
+#############################################################
+ENCHANT_VERSION = 1.5.0
+ENCHANT_SOURCE = enchant-$(ENCHANT_VERSION).tar.gz
+ENCHANT_SITE = http://www.abisource.com/downloads/enchant/$(ENCHANT_VERSION)
+
+ENCHANT_INSTALL_STAGING = YES
+ENCHANT_INSTALL_TARGET = YES
+ENCHANT_LIBTOOL_PATCH = NO
+
+$(eval $(call AUTOTARGETS,package,enchant))