bootutils: drop package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 30 Sep 2018 14:02:06 +0000 (16:02 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 30 Sep 2018 18:16:53 +0000 (20:16 +0200)
As suggested by Romain Naour during review of patch 976582
(https://patchwork.ozlabs.org/patch/976582), drop bootutils as "upstream
is dead since 2009" and "BootUtils is a collection of utilities to
facilitate booting of modern Kernel 2.6 based systems"

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/bootutils/0001-fix-build-with-glibc-2.28.patch [deleted file]
package/bootutils/Config.in [deleted file]
package/bootutils/bootutils.hash [deleted file]
package/bootutils/bootutils.mk [deleted file]

index e1a0276b7d8cd981c2f556ecac1942f3e743cab4..20e2d5c8c6f5cb2c6bb1b08449eb215c178549f4 100644 (file)
@@ -145,6 +145,12 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2018.11"
 
+config BR2_PACKAGE_BOOTUTILS
+       bool "bootutils package removed"
+       select BR2_LEGACY
+       help
+         The bootutils package was removed.
+
 config BR2_PACKAGE_EXPEDITE
        bool "expedite package has been removed"
        select BR2_LEGACY
index 125e8ca7dc635e5eae9cd85a8479df4c76ca252a..2e163f185264c4600c0ed3b2b95de4b4157c7b78 100644 (file)
@@ -2048,7 +2048,6 @@ menu "System tools"
        source "package/atop/Config.in"
        source "package/attr/Config.in"
        source "package/audit/Config.in"
-       source "package/bootutils/Config.in"
        source "package/cgroupfs-mount/Config.in"
        source "package/circus/Config.in"
        source "package/coreutils/Config.in"
diff --git a/package/bootutils/0001-fix-build-with-glibc-2.28.patch b/package/bootutils/0001-fix-build-with-glibc-2.28.patch
deleted file mode 100644 (file)
index fced93d..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-From 00773e89893e4aaed721269eee0dbf844edd291c Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sat, 29 Sep 2018 12:56:14 +0200
-Subject: [PATCH] fix build with glibc 2.28
-
-Include to sys/sysmacros.h is needed to use makedev since glibc 2.28 so
-add this include to devname.c and raidscan.c
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- libblkid/devname.c | 1 +
- raidscan.c         | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/libblkid/devname.c b/libblkid/devname.c
-index d11bddd..12b63db 100644
---- a/libblkid/devname.c
-+++ b/libblkid/devname.c
-@@ -37,6 +37,7 @@
- #if HAVE_SYS_MKDEV_H
- #include <sys/mkdev.h>
- #endif
-+#include <sys/sysmacros.h>
- #include <time.h>
- #include "blkidP.h"
-diff --git a/raidscan.c b/raidscan.c
-index fab3b02..6e07b3d 100644
---- a/raidscan.c
-+++ b/raidscan.c
-@@ -22,6 +22,7 @@
- #include "config.h"
- #include <sys/stat.h>
-+#include <sys/sysmacros.h>
- #include <fcntl.h>
- #include <sys/ioctl.h>
- #include <linux/major.h>
--- 
-2.17.1
-
diff --git a/package/bootutils/Config.in b/package/bootutils/Config.in
deleted file mode 100644 (file)
index 30d647a..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_BOOTUTILS
-       bool "bootutils"
-       depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
-       help
-         BootUtils is a collection of utilities to facilitate booting
-         of Linux 2.6-based systems. The process of finding the root
-         volume either by label or explicit label= on the kernel
-         command line, mounting it, and 'switchroot'ing is automated.
-
-         http://bootutils.sourceforge.net/
diff --git a/package/bootutils/bootutils.hash b/package/bootutils/bootutils.hash
deleted file mode 100644 (file)
index 576c324..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally computed:
-sha256  78549714e7c7fa246a4019c245f4da044aee6cfe48ad6887c4013ac4c749c7b9  bootutils-1.0.0.tar.gz
diff --git a/package/bootutils/bootutils.mk b/package/bootutils/bootutils.mk
deleted file mode 100644 (file)
index bc4b3e8..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-################################################################################
-#
-# bootutils
-#
-################################################################################
-
-BOOTUTILS_VERSION = 1.0.0
-BOOTUTILS_SITE = http://downloads.sourceforge.net/project/bootutils/Stable/v$(BOOTUTILS_VERSION)
-BOOTUTILS_CONF_OPTS = --prefix=/ --exec-prefix=/
-BOOTUTILS_LICENSE = GPL-2.0+
-BOOTUTILS_LICENSE_FILES = COPYING
-
-$(eval $(autotools-package))