package/python-pytest-asyncio: new package
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Tue, 22 Dec 2020 16:39:15 +0000 (17:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 31 Dec 2020 14:10:16 +0000 (15:10 +0100)
Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-pytest-asyncio/Config.in [new file with mode: 0644]
package/python-pytest-asyncio/python-pytest-asyncio.hash [new file with mode: 0644]
package/python-pytest-asyncio/python-pytest-asyncio.mk [new file with mode: 0644]

index 263b57c3087e37090c5dd4d9c77e257c40523ec6..104f44d40c54072db3da243dfe8224e6445f52c7 100644 (file)
@@ -1604,6 +1604,7 @@ F:        package/python-intelhex/
 F:     package/python-packaging/
 F:     package/python-pluggy/
 F:     package/python-pytest/
+F:     package/python-pytest-asyncio/
 F:     package/python-typing-extensions/
 F:     package/python-xmodem/
 F:     package/rs485conf/
index 30bb5814d2edffd106055de4d5987ede19a90dc7..1a85a891aa615b9494772f15903c79a9eefc05aa 100644 (file)
@@ -1137,6 +1137,7 @@ menu "External python modules"
        source "package/python-pytablereader/Config.in"
        source "package/python-pytablewriter/Config.in"
        source "package/python-pytest/Config.in"
+       source "package/python-pytest-asyncio/Config.in"
        source "package/python-pytrie/Config.in"
        source "package/python-pytz/Config.in"
        source "package/python-pyudev/Config.in"
diff --git a/package/python-pytest-asyncio/Config.in b/package/python-pytest-asyncio/Config.in
new file mode 100644 (file)
index 0000000..3fa90e4
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_PYTEST_ASYNCIO
+       bool "python-pytest-asyncio"
+       depends on BR2_PACKAGE_PYTHON3 # pytest
+       select BR2_PACKAGE_PYTHON_PYTEST # runtime
+       help
+         Pytest support for asyncio.
+
+         https://github.com/pytest-dev/pytest-asyncio
diff --git a/package/python-pytest-asyncio/python-pytest-asyncio.hash b/package/python-pytest-asyncio/python-pytest-asyncio.hash
new file mode 100644 (file)
index 0000000..40541f5
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/pytest-asyncio/json
+md5  b63593bc08f445f6e3f14c34128a68ed  pytest-asyncio-0.14.0.tar.gz
+sha256  9882c0c6b24429449f5f969a5158b528f39bde47dc32e85b9f0403965017e700  pytest-asyncio-0.14.0.tar.gz
+# Locally computed sha256 checksums
+sha256  cb5e8e7e5f4a3988e1063c142c60dc2df75605f4c46515e776e3aca6df976e14  LICENSE
diff --git a/package/python-pytest-asyncio/python-pytest-asyncio.mk b/package/python-pytest-asyncio/python-pytest-asyncio.mk
new file mode 100644 (file)
index 0000000..0645db3
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-pytest-asyncio
+#
+################################################################################
+
+PYTHON_PYTEST_ASYNCIO_VERSION = 0.14.0
+PYTHON_PYTEST_ASYNCIO_SOURCE = pytest-asyncio-$(PYTHON_PYTEST_ASYNCIO_VERSION).tar.gz
+PYTHON_PYTEST_ASYNCIO_SITE = https://files.pythonhosted.org/packages/65/09/9472d4db0625cf56d40f4e405f955faf6469be00858a273b71332f3fcd1f
+PYTHON_PYTEST_ASYNCIO_SETUP_TYPE = setuptools
+PYTHON_PYTEST_ASYNCIO_LICENSE = Apache-2.0
+PYTHON_PYTEST_ASYNCIO_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))