package/php: security bump to 7.1.13
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 6 Jan 2018 18:36:57 +0000 (19:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Jan 2018 14:05:45 +0000 (15:05 +0100)
Removed 0008-fix-asm-constraints-in-aarch64-multiply-macro.patch, patch
was applied upstream:
https://github.com/php/php-src/commit/d6d4f2a9b38cd7fa7e938142e49e5a514d612e52

Renumbered patch 0009.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/0008-Call-apxs-with-correct-prefix.patch [new file with mode: 0644]
package/php/0008-fix-asm-constraints-in-aarch64-multiply-macro.patch [deleted file]
package/php/0009-Call-apxs-with-correct-prefix.patch [deleted file]
package/php/php.hash
package/php/php.mk

diff --git a/package/php/0008-Call-apxs-with-correct-prefix.patch b/package/php/0008-Call-apxs-with-correct-prefix.patch
new file mode 100644 (file)
index 0000000..b850ab7
--- /dev/null
@@ -0,0 +1,49 @@
+From 4342bdea7a1a21430ce0d051fa4387441166c473 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fabrice.fontaine@orange.com>
+Date: Sun, 11 Dec 2016 23:12:46 +0100
+Subject: [PATCH] Call apxs with correct prefix
+
+php uses apache's apxs script from staging directory to install libphp
+dynamic library and update /etc/apache2/httpd.conf in the staging and target
+directories. Here is the full command line:
+"apxs -S LIBEXECDIR='$(INSTALL_ROOT)/usr/modules'
+ -S SYSCONFDIR='$(INSTALL_ROOT)/etc/apache2' -i -a -n php7"
+This does not work for target directory as apxs sets the full path of the
+library and not the relative one. Indeed, apxs is smart enough to substitute
+away the prefix specified in $(STAGING_DIR)/usr/build/config_vars.mk so
+httpd.conf will only be correct in the staging directory.
+To fix this, add -S PREFIX='$(INSTALL_ROOT)/usr' to apxs call in configure
+
+Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
+---
+ sapi/apache2handler/config.m4 | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/sapi/apache2handler/config.m4 b/sapi/apache2handler/config.m4
+index 2e64b21..f5bf002 100644
+--- a/sapi/apache2handler/config.m4
++++ b/sapi/apache2handler/config.m4
+@@ -66,10 +66,12 @@ if test "$PHP_APXS2" != "no"; then
+     AC_MSG_ERROR([Please note that Apache version >= 2.0.44 is required])
+   fi
++  APXS_PREFIX='$(INSTALL_ROOT)'/usr
+   APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
+   if test -z `$APXS -q SYSCONFDIR`; then
+     INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
+                  $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
++                       -S PREFIX='$APXS_PREFIX' \
+                        -i -n php7"
+   else
+     APXS_SYSCONFDIR='$(INSTALL_ROOT)'`$APXS -q SYSCONFDIR`
+@@ -77,6 +79,7 @@ if test "$PHP_APXS2" != "no"; then
+                 \$(mkinstalldirs) '$APXS_SYSCONFDIR' && \
+                  $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
+                        -S SYSCONFDIR='$APXS_SYSCONFDIR' \
++                       -S PREFIX='$APXS_PREFIX' \
+                        -i -a -n php7"
+   fi
+-- 
+2.5.0
+
diff --git a/package/php/0008-fix-asm-constraints-in-aarch64-multiply-macro.patch b/package/php/0008-fix-asm-constraints-in-aarch64-multiply-macro.patch
deleted file mode 100644 (file)
index f4812da..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From 1622f24fde4220967bd907bf8f0325d444bf9339 Mon Sep 17 00:00:00 2001
-From: Andy Postnikov <apostnikov@gmail.com>
-Date: Sat, 10 Dec 2016 23:51:17 +0300
-Subject: [PATCH] Fix bug #70015 - Compilation failure on aarch64
-
-Fixes build at -O0.
-
-[From pull request https://github.com/php/php-src/pull/2236.]
-Signed-off-by: Tatsuyuki Ishi <ishitatsuyuki@gmail.com>
----
- Zend/zend_multiply.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Zend/zend_multiply.h b/Zend/zend_multiply.h
-index 75769db..fbd69ab 100644
---- a/Zend/zend_multiply.h
-+++ b/Zend/zend_multiply.h
-@@ -75,8 +75,8 @@
-       __asm__("mul %0, %2, %3\n"                                                                              \
-               "smulh %1, %2, %3\n"                                                                            \
-               "sub %1, %1, %0, asr #63\n"                                                                     \
--                      : "=X"(__tmpvar), "=X"(usedval)                                                 \
--                      : "X"(a), "X"(b));                                                                              \
-+                      : "=&r"(__tmpvar), "=&r"(usedval)                                               \
-+                      : "r"(a), "r"(b));                                                                              \
-       if (usedval) (dval) = (double) (a) * (double) (b);                              \
-       else (lval) = __tmpvar;                                                                                 \
- } while (0)
diff --git a/package/php/0009-Call-apxs-with-correct-prefix.patch b/package/php/0009-Call-apxs-with-correct-prefix.patch
deleted file mode 100644 (file)
index b850ab7..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From 4342bdea7a1a21430ce0d051fa4387441166c473 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fabrice.fontaine@orange.com>
-Date: Sun, 11 Dec 2016 23:12:46 +0100
-Subject: [PATCH] Call apxs with correct prefix
-
-php uses apache's apxs script from staging directory to install libphp
-dynamic library and update /etc/apache2/httpd.conf in the staging and target
-directories. Here is the full command line:
-"apxs -S LIBEXECDIR='$(INSTALL_ROOT)/usr/modules'
- -S SYSCONFDIR='$(INSTALL_ROOT)/etc/apache2' -i -a -n php7"
-This does not work for target directory as apxs sets the full path of the
-library and not the relative one. Indeed, apxs is smart enough to substitute
-away the prefix specified in $(STAGING_DIR)/usr/build/config_vars.mk so
-httpd.conf will only be correct in the staging directory.
-To fix this, add -S PREFIX='$(INSTALL_ROOT)/usr' to apxs call in configure
-
-Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
----
- sapi/apache2handler/config.m4 | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/sapi/apache2handler/config.m4 b/sapi/apache2handler/config.m4
-index 2e64b21..f5bf002 100644
---- a/sapi/apache2handler/config.m4
-+++ b/sapi/apache2handler/config.m4
-@@ -66,10 +66,12 @@ if test "$PHP_APXS2" != "no"; then
-     AC_MSG_ERROR([Please note that Apache version >= 2.0.44 is required])
-   fi
-+  APXS_PREFIX='$(INSTALL_ROOT)'/usr
-   APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
-   if test -z `$APXS -q SYSCONFDIR`; then
-     INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
-                  $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
-+                       -S PREFIX='$APXS_PREFIX' \
-                        -i -n php7"
-   else
-     APXS_SYSCONFDIR='$(INSTALL_ROOT)'`$APXS -q SYSCONFDIR`
-@@ -77,6 +79,7 @@ if test "$PHP_APXS2" != "no"; then
-                 \$(mkinstalldirs) '$APXS_SYSCONFDIR' && \
-                  $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
-                        -S SYSCONFDIR='$APXS_SYSCONFDIR' \
-+                       -S PREFIX='$APXS_PREFIX' \
-                        -i -a -n php7"
-   fi
--- 
-2.5.0
-
index cdec308b66386a9cc1586135c727da16bee8db3d..3b3c97bd38129d5aa574afeb6d756657866a73d4 100644 (file)
@@ -1,5 +1,5 @@
 # From http://php.net/downloads.php
-sha256 a0118850774571b1f2d4e30b4fe7a4b958ca66f07d07d65ebdc789c54ba6eeb3  php-7.1.12.tar.xz
+sha256 1a0b3f2fb61959b57a3ee01793a77ed3f19bde5aa90c43dcacc85ea32f64fc10  php-7.1.13.tar.xz
 
 # License file
 sha256 a44951f93b10c87c3f7cd9f311d95999c57c95ed950eec32b14c1c7ea6baf25e  LICENSE
index 72d5ea80c711252c6cfcbc61302c75a1c5553c5c..941000cd6b019eb851a687a6d207b455de041802 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-PHP_VERSION = 7.1.12
+PHP_VERSION = 7.1.13
 PHP_SITE = http://www.php.net/distributions
 PHP_SOURCE = php-$(PHP_VERSION).tar.xz
 PHP_INSTALL_STAGING = YES