wavpack: fix broken link on newer binutils
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 29 Dec 2012 03:06:11 +0000 (03:06 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 29 Dec 2012 13:30:59 +0000 (14:30 +0100)
Newer versions of binutils (2.22+) default to --no-copy-dt-needed hence
all the used libraries must be explicitly named.
This is accounted for in the source configure script but not in the
compiled form so we just need to autoreconf it.

[Peter: add comment why autoconf is needed]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/wavpack/wavpack.mk

index 4b1c59e762dcfdfe54b09fdb4b4553ae39c8fd0b..cd9b4f78bba91fe95e1be2e6c414bfcff2aec506 100644 (file)
@@ -8,9 +8,10 @@ WAVPACK_VERSION = 4.60.1
 WAVPACK_SITE = http://www.wavpack.com
 WAVPACK_SOURCE = wavpack-$(WAVPACK_VERSION).tar.bz2
 WAVPACK_INSTALL_STAGING = YES
-
-ifneq ($(BR2_ENABLE_LOCALE),y)
-WAVPACK_DEPENDENCIES += libiconv
-endif
+# configure not up to date
+WAVPACK_AUTORECONF = YES
+WAVPACK_DEPENDENCIES = $(if $(BR2_ENABLE_LOCALE),libiconv)
+WAVPACK_LICENSE = BSD-3c
+WAVPACK_LICENSE_FILES = license.txt
 
 $(eval $(autotools-package))