gst1-plugins-base: add opus support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 25 Mar 2016 12:50:07 +0000 (09:50 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 26 Mar 2016 15:52:38 +0000 (16:52 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer1/gst1-plugins-base/Config.in
package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk

index b19fa59b92156a6277de384d3261330a1f6cea8c..22541e19cade160eb5442b72b2872838b7653945 100644 (file)
@@ -126,6 +126,12 @@ config BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_OGG
        help
          ogg stream manipulation (info about ogg: http://xiph.org)
 
+config BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_OPUS
+       bool "opus"
+       select BR2_PACKAGE_OPUS
+       help
+         Opus codec for speech and audio.
+
 config BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_PANGO
        bool "pango font renderer"
        depends on BR2_INSTALL_LIBSTDCPP # pango -> freetype
index 94902964808cdf4db32df26978a9d13b36a886c3..d7feb7c78560a7e1002b61d1b0d0f1a53085021b 100644 (file)
@@ -176,6 +176,13 @@ else
 GST1_PLUGINS_BASE_CONF_OPTS += --disable-ivorbis
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_OPUS),y)
+GST1_PLUGINS_BASE_CONF_OPTS += --enable-opus
+GST1_PLUGINS_BASE_DEPENDENCIES += opus
+else
+GST1_PLUGINS_BASE_CONF_OPTS += --disable-opus
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_OGG),y)
 GST1_PLUGINS_BASE_CONF_OPTS += --enable-ogg
 GST1_PLUGINS_BASE_DEPENDENCIES += libogg