dependencies: check for extract tools as well
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Dec 2011 19:23:04 +0000 (20:23 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Dec 2011 19:27:21 +0000 (20:27 +0100)
Most of the extract tools (gzip/bzip/..) we already check for explicitly
in dependencies.sh (as they are used outside GENTARGETS), but not for
xzcat.
The .xz format is used fairly rarely, and it is likely to not be available
on build hosts, so an explicit (hardcoded) check for it isn't optimal.
Instead, add the inflate tools used to DL_TOOLS_DEPENDENCIES, similar to
how we do it for svn/git/bzr/...

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.package.in
toolchain/dependencies/dependencies.mk

index 2349b05af864ffb1da42696ab445ef640f768b22..e85eb15490bd70e53c6fa4eedfa961a980b5ee98 100644 (file)
@@ -726,6 +726,8 @@ else ifeq ($$($(2)_SITE_METHOD),hg)
 DL_TOOLS_DEPENDENCIES += hg
 endif # SITE_METHOD
 
+DL_TOOLS_DEPENDENCIES += $(firstword $(INFLATE$(suffix $($(2)_SOURCE))))
+
 endif # $(2)_KCONFIG_VAR
 endef # GENTARGETS_INNER
 
index 24d66663bb769a87506612dc08279bd4acbc3008..ea8bf252bd0a14eb7de7583354858b93b0248462 100644 (file)
@@ -10,16 +10,10 @@ ifeq ($(BR2_STRIP_sstrip),y)
 DEPENDENCIES_HOST_PREREQ+=host-sstrip
 endif
 
-# Remove duplicate entries from $(DL_TOOLS_DEPENDENCIES)
-DL_TOOLS = \
-       $(findstring svn,$(DL_TOOLS_DEPENDENCIES)) \
-       $(findstring git,$(DL_TOOLS_DEPENDENCIES)) \
-       $(findstring bzr,$(DL_TOOLS_DEPENDENCIES))
-
 core-dependencies:
        @HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
                CONFIG_FILE="$(CONFIG_DIR)/.config" \
-               DL_TOOLS="$(DL_TOOLS)" \
+               DL_TOOLS="$(sort $(DL_TOOLS_DEPENDENCIES))" \
                $(TOPDIR)/toolchain/dependencies/dependencies.sh
 
 dependencies: core-dependencies $(DEPENDENCIES_HOST_PREREQ)