coreutils: avoid prompt on rebuild
authorBaruch Siach <baruch@tkos.co.il>
Tue, 18 Nov 2014 19:07:28 +0000 (21:07 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 18 Nov 2014 20:49:30 +0000 (21:49 +0100)
The mode bits of coreutils installed binaries are 555. As a result, on
rebuild mv prompts the user to confirm overwrite of non writable binaries.
Force overwrite to skip this prompt.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/coreutils/coreutils.mk

index e06510e096fefc107b3c0b5b95cd8e36f7e718c5..db0d8a941f5a8bf90fccb619cd669605f5e1eb05 100644 (file)
@@ -102,12 +102,12 @@ endif
 define COREUTILS_POST_INSTALL
        # some things go in root rather than usr
        for f in $(COREUTILS_BIN_PROGS); do \
-               mv $(TARGET_DIR)/usr/bin/$$f $(TARGET_DIR)/bin/$$f; \
+               mv -f $(TARGET_DIR)/usr/bin/$$f $(TARGET_DIR)/bin/$$f; \
        done
        # link for archaic shells
        ln -fs test $(TARGET_DIR)/usr/bin/[
        # gnu thinks chroot is in bin, debian thinks it's in sbin
-       mv $(TARGET_DIR)/usr/bin/chroot $(TARGET_DIR)/usr/sbin/chroot
+       mv -f $(TARGET_DIR)/usr/bin/chroot $(TARGET_DIR)/usr/sbin/chroot
 endef
 
 COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_POST_INSTALL