linux: enable CONFIG_AUDIT if the audit package is selected
authorCarlos Santos <casantos@datacom.com.br>
Sat, 3 Nov 2018 16:42:43 +0000 (13:42 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 3 Nov 2018 21:22:05 +0000 (22:22 +0100)
We already turn on kernel features for several packages, so let's do it
for audit too, since the daemon is useless and fails to load otherwise.

Notice that we also turn NET on, since AUDIT depends on NET, like we do
for the wireguard package.

Signed-off-by: Carlos Santos <casantos@datacom.com.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/linux.mk

index e9c75153b29433bd55a3ba2fe533e6bb7f69283b..476ff1632943cb1574afe9e00c8e4cbc778f1987 100644 (file)
@@ -320,6 +320,9 @@ define LINUX_KCONFIG_FIXUP_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.config))
        $(if $(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV),
                $(call KCONFIG_ENABLE_OPT,CONFIG_INOTIFY_USER,$(@D)/.config))
+       $(if $(BR2_PACKAGE_AUDIT),
+               $(call KCONFIG_ENABLE_OPT,CONFIG_NET,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_AUDIT,$(@D)/.config))
        $(if $(BR2_PACKAGE_KTAP),
                $(call KCONFIG_ENABLE_OPT,CONFIG_DEBUG_FS,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_ENABLE_DEFAULT_TRACERS,$(@D)/.config)