util-linux: enable libmount for host variant
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 20 Sep 2016 20:27:43 +0000 (17:27 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 21 Sep 2016 03:53:00 +0000 (05:53 +0200)
It's a necessary dependency to build the new host-libglib2.
libblkd is an indirect dependency for libmount.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/util-linux.mk

index 82a726e939d35f3acf91686dd188243b7e58c419..f648155445148d3248e8f6bc81a21267b8f7cd0e 100644 (file)
@@ -117,13 +117,14 @@ UTIL_LINUX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_UTIL_LINUX_WRITE),--enable-write,--disable-write) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_ZRAMCTL),--enable-zramctl,--disable-zramctl)
 
-# In the host version of util-linux, we so far only require libuuid,
-# and none of the util-linux utilities, so we disable all of them, unless
-# BR2_PACKAGE_HOST_UTIL_LINUX is set
+# In the host version of util-linux, we only require libuuid and
+# libmount (plus libblkid as an indirect dependency of libmount).
+# So disable all of the programs, unless BR2_PACKAGE_HOST_UTIL_LINUX is set
 
 HOST_UTIL_LINUX_CONF_OPTS += \
+       --enable-libblkid \
+       --enable-libmount \
        --enable-libuuid \
-       --disable-libblkid --disable-libmount \
        --without-ncurses
 
 ifeq ($(BR2_PACKAGE_HOST_UTIL_LINUX),y)