glibc: install libmvec.so when available
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Oct 2016 21:47:58 +0000 (23:47 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 27 Oct 2016 08:40:15 +0000 (10:40 +0200)
On some architectures (namely x86-64), glibc may provide a libmvec
library since glibc 2.22, which programs built with gcc OpenMP support
might get linked to.

In order for these programs to work on the target, we need to copy
this library to the target filesystem.

This commit takes care of this for the glibc package (used for the
internal toolchain backend). Note that libraries listed in
GLIBC_LIBS_LIB are silently ignored if they don't exist. Therefore, we
don't need to have any condition on the architecture or glibc version.

For more details on libmvec, see
https://sourceware.org/glibc/wiki/libmvec.

Fixes bug #9111.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/glibc/glibc.mk

index 50154e851ad02c1ce46a9047922a23a63e22e9e6..c11f7cd867f2fcef7f351a11428bbcdac37f4502 100644 (file)
@@ -103,7 +103,7 @@ endef
 GLIBC_LIBS_LIB = \
        ld*.so.* libc.so.* libcrypt.so.* libdl.so.* libgcc_s.so.* libm.so.*        \
        libnsl.so.* libpthread.so.* libresolv.so.* librt.so.* libutil.so.*   \
-       libnss_files.so.* libnss_dns.so.*
+       libnss_files.so.* libnss_dns.so.* libmvec.so.*
 
 ifeq ($(BR2_PACKAGE_GDB),y)
 GLIBC_LIBS_LIB += libthread_db.so.*