tstools: GitHub migration
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Tue, 20 Oct 2015 13:06:14 +0000 (14:06 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 20 Oct 2015 14:33:07 +0000 (16:33 +0200)
tstools has migrated to GitHub, so let's use this opportuninty to rework
this package as well.

- Change site to GitHub.
- No releases of tags yet, so let's use the latest commit ID from the
  master branch as a version.
- There is currently no license file attributed to tstools, so state that
  in the tstools.mk file and add empty license file variable. This issue is
  being tracked upstream: https://github.com/kynesim/tstools/issues/32
- Wrap the help text in the Config.in to 72 characters, and also change
  the project URL to the GitHub one.
- Add a hash file.
- Rename the patch to use a four digit numbering (001 -> 0001).

[Peter: leave license as MPLv1.1, adjust comment to match]
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tstools/0001-build-get-along-with-buildroot.patch [new file with mode: 0644]
package/tstools/001-build-get-along-with-buildroot.patch [deleted file]
package/tstools/Config.in
package/tstools/tstools.hash [new file with mode: 0644]
package/tstools/tstools.mk

diff --git a/package/tstools/0001-build-get-along-with-buildroot.patch b/package/tstools/0001-build-get-along-with-buildroot.patch
new file mode 100644 (file)
index 0000000..1e7a748
--- /dev/null
@@ -0,0 +1,40 @@
+From 44f80bce0914d4d9c5e7486c7cdb521ba637b324 Mon Sep 17 00:00:00 2001
+From: Tzu-Jung Lee <tjlee@ambarella.com>
+Date: Fri, 19 Jul 2013 22:45:18 +0800
+Subject: [PATCH] build: get along with buildroot
+
+Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
+---
+ Makefile | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2c3568e..98bb994 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,12 +34,6 @@ SHELL = /bin/sh
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+-ifdef CROSS_COMPILE
+-CC = $(CROSS_COMPILE)gcc
+-else
+-CC = gcc
+-endif
+-
+ # Use WARN=1 periodically to get too many warnings...
+ ifdef WARN
+ WARNING_FLAGS = -Wall -W -Wfloat-equal -Wundef -Wshadow -Wpointer-arith -Wcast-qual -Wconversion -Wmissing-prototypes -Wmissing-declarations -Wunreachable-code -Winline
+@@ -452,3 +446,9 @@ test_lists:        $(BINDIR)/test_nal_unit_list  $(BINDIR)/test_es_unit_list
+       @echo +++ Testing ES unit lists
+       $(BINDIR)/test_es_unit_list
+       @echo +++ Test succeeded
++
++.PHONY: install
++install:
++      @for i in $(PROGS); do \
++              cp -f $$i $(DESTDIR)/usr/bin/; \
++      done
+-- 
+1.8.3.2
+
diff --git a/package/tstools/001-build-get-along-with-buildroot.patch b/package/tstools/001-build-get-along-with-buildroot.patch
deleted file mode 100644 (file)
index 1e7a748..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-From 44f80bce0914d4d9c5e7486c7cdb521ba637b324 Mon Sep 17 00:00:00 2001
-From: Tzu-Jung Lee <tjlee@ambarella.com>
-Date: Fri, 19 Jul 2013 22:45:18 +0800
-Subject: [PATCH] build: get along with buildroot
-
-Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
----
- Makefile | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 2c3568e..98bb994 100644
---- a/Makefile
-+++ b/Makefile
-@@ -34,12 +34,6 @@ SHELL = /bin/sh
- .SUFFIXES:
- .SUFFIXES: .c .o
--ifdef CROSS_COMPILE
--CC = $(CROSS_COMPILE)gcc
--else
--CC = gcc
--endif
--
- # Use WARN=1 periodically to get too many warnings...
- ifdef WARN
- WARNING_FLAGS = -Wall -W -Wfloat-equal -Wundef -Wshadow -Wpointer-arith -Wcast-qual -Wconversion -Wmissing-prototypes -Wmissing-declarations -Wunreachable-code -Winline
-@@ -452,3 +446,9 @@ test_lists:        $(BINDIR)/test_nal_unit_list  $(BINDIR)/test_es_unit_list
-       @echo +++ Testing ES unit lists
-       $(BINDIR)/test_es_unit_list
-       @echo +++ Test succeeded
-+
-+.PHONY: install
-+install:
-+      @for i in $(PROGS); do \
-+              cp -f $$i $(DESTDIR)/usr/bin/; \
-+      done
--- 
-1.8.3.2
-
index 706cb54330633c2a2b2f42bdfc30a6d7ba04bba1..f5dd138c4d123d43d653add441cfda9bea8073f6 100644 (file)
@@ -2,16 +2,15 @@ config BR2_PACKAGE_TSTOOLS
        bool "tstools"
        depends on BR2_USE_MMU # fork()
        help
-         This is a set of cross-platform command line tools for
-         working with MPEG data
+         This is a set of cross-platform command line tools for working with
+         MPEG data.
 
-         The emphasis is on relatively simple tools which concentrate
-         on MPEG (H.264 and H.262) data packaged according to H.222
-         (i.e., TS or PS), with a particular interest in checking for
-         conformance.
+         The emphasis is on relatively simple tools which concentrate on MPEG
+         (H.264 and H.262) data packaged according to H.222 (i.e., TS or PS),
+         with a particular interest in checking for conformance.
 
-         Transport Stream (TS) is typically used for distribution of
-         cable and satellite data. Program Stream (PS) is typically
-         used to store data on DVDs.
+         Transport Stream (TS) is typically used for distribution of cable
+         and satellite data. Program Stream (PS) is typically used to store
+         data on DVDs.
 
-         https://code.google.com/p/tstools/
+         https://github.com/kynesim/tstools/
diff --git a/package/tstools/tstools.hash b/package/tstools/tstools.hash
new file mode 100644 (file)
index 0000000..9b0f1c7
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 3d2b2375e2874933f9aa59d4f25bb6b334747219eb0d7a076974e61222d59bf6  tstools-08f6be304040e7b84760ac3920bcff4a563b6cd2.tar.gz
index 40920d2575d9a51acaa625bb7e91ac2fcb2baaa0..3355db864bab95a1d855dedcdcad80dbb094543b 100644 (file)
@@ -4,10 +4,13 @@
 #
 ################################################################################
 
-TSTOOLS_VERSION = 1_11
-TSTOOLS_SITE = https://tstools.googlecode.com/files
-TSTOOLS_SOURCE = tstools-$(TSTOOLS_VERSION).tgz
-TSTOOLS_LICENSE = MPL v1.1
+# No releases or tags yet. Use the latest commit ID from master branch.
+TSTOOLS_VERSION = 08f6be304040e7b84760ac3920bcff4a563b6cd2
+TSTOOLS_SITE = $(call github,kynesim,tstools,$(TSTOOLS_VERSION))
+# tstools upstream doesn't contain any license file so far. See:
+# https://github.com/kynesim/tstools/issues/32
+TSTOOLS_LICENSE = MPLv1.1
+TSTOOLS_LICENSE_FILES =
 
 define TSTOOLS_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) LD="$(TARGET_CC)" $(TARGET_MAKE_ENV) \