package/luajit: switch to moonjit fork
authorFrancois Perrad <fperrad@gmail.com>
Wed, 4 Dec 2019 08:38:45 +0000 (09:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 6 Dec 2019 22:47:27 +0000 (23:47 +0100)
This fork is based on LuaJIT 2.1.0-beta3 which supports ARM64.

The license file is changed with the copyright from the Moonjit
developers, and an additional copy of the MIT license. Therefore the
license terms are still the same: MIT.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: add details about why the hash of the license file changes]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/luajit/0001-no-bin-symlink.patch
package/luajit/0002-install-inc.patch
package/luajit/Config.in
package/luajit/luajit.hash
package/luajit/luajit.mk

index dd1dfd89fceec56aa00baca9116faaf663856bfb..d32ec5ad6044d203b12e1cacd235ee5b93122c45 100644 (file)
@@ -6,7 +6,7 @@ Index: b/Makefile
 ===================================================================
 --- a/Makefile
 +++ b/Makefile
-@@ -43,8 +43,7 @@
+@@ -44,8 +44,7 @@
  INSTALL_MAN= $(INSTALL_SHARE)/man/man1
  INSTALL_PKGCONFIG= $(INSTALL_LIB)/pkgconfig
  
@@ -16,7 +16,7 @@ Index: b/Makefile
  INSTALL_ANAME= libluajit-$(ABIVER).a
  INSTALL_SOSHORT1= libluajit-$(ABIVER).so
  INSTALL_SOSHORT2= libluajit-$(ABIVER).so.$(MAJVER)
-@@ -59,7 +58,6 @@
+@@ -60,7 +59,6 @@
  INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT1)
  INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT2)
  INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
index 86b766dfc4427e4f6b637ff4058948a58e03b152..5f6547fc3fefaa46ebc137bd71166e7bf3e6dad8 100644 (file)
@@ -6,7 +6,7 @@ Index: b/Makefile
 ===================================================================
 --- a/Makefile
 +++ b/Makefile
-@@ -32,7 +32,7 @@
+@@ -33,7 +33,7 @@
  INSTALL_BIN=   $(DPREFIX)/bin
  INSTALL_LIB=   $(DPREFIX)/$(MULTILIB)
  INSTALL_SHARE= $(DPREFIX)/share
index 88c5bcbf28043610d557aea2547355e6df2de8ac..f4d60015868a8d8e1a7685bd95739abbacc18ed1 100644 (file)
@@ -2,7 +2,7 @@ config BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
        bool
        default y if BR2_i386 || \
                (BR2_x86_64 && BR2_HOSTARCH='x86_64') || \
-               BR2_powerpc || BR2_arm || BR2_armeb || \
+               BR2_powerpc || BR2_arm || BR2_armeb || BR2_aarch64 || \
                ((BR2_mips || BR2_mipsel) && !BR2_MIPS_SOFT_FLOAT && \
                !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6)
        # -m32 flag is used for 32bit builds and host-luajit has
@@ -26,7 +26,7 @@ config BR2_PACKAGE_LUAJIT
          ABI-compatible to the standard Lua interpreter and can be
          deployed as a drop-in replacement.
 
-         http://luajit.org/
+         https://github.com/moonjit/moonjit
 
 if BR2_PACKAGE_LUAJIT
 
index 7e2d87ebb20441e8efbeb5b73521afe56dfb11c3..532ec0b29442168988e65ab8943671ad5138e571 100644 (file)
@@ -1,5 +1,5 @@
-# Hashes from: http://luajit.org/download.html
-md5 48353202cbcacab84ee41a5a70ea0a2c    LuaJIT-2.0.5.tar.gz
+# Locally calculated
+sha256 c3de8e29aa617fc594c043f57636ab9ad71af2b4a3a513932b05f5cdaa4320b2  luajit-2.1.2.tar.gz
 
 # Locally calculated
-sha256 accb335aa3102f80d31caa2c2508fbcb795314106493519a367f13a87d0e87de  COPYRIGHT
+sha256 aa64a7706ded773011b933f4230d7b35ba662598197f82ac2c7bca62abdaa4d7  COPYRIGHT
index 5b08a42d9861a4bbc580dae2226e53720e8e0b8c..68e6af4f5e7c48fd5f7a0655b7a432b9454dca82 100644 (file)
@@ -4,9 +4,8 @@
 #
 ################################################################################
 
-LUAJIT_VERSION = 2.0.5
-LUAJIT_SOURCE = LuaJIT-$(LUAJIT_VERSION).tar.gz
-LUAJIT_SITE = http://luajit.org/download
+LUAJIT_VERSION = 2.1.2
+LUAJIT_SITE = $(call github,moonjit,moonjit,$(LUAJIT_VERSION))
 LUAJIT_LICENSE = MIT
 LUAJIT_LICENSE_FILES = COPYRIGHT