package/kodi-pvr-vuplus: bump version
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Jan 2020 11:07:24 +0000 (12:07 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 23 Jan 2020 00:04:02 +0000 (01:04 +0100)
Added dependency to json-for-modern-cpp after upstream commit:
https://github.com/kodi-pvr/pvr.vuplus/commit/07480b96fc674317ccbb792b03b811edec143e0c

Also added missing dependency to tinyxml.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/kodi-pvr-vuplus/Config.in
package/kodi-pvr-vuplus/kodi-pvr-vuplus.hash
package/kodi-pvr-vuplus/kodi-pvr-vuplus.mk

index a56c4ede93aae924fc04b1a63ef5d568f51e0f53..96320f6fcba01470c187ec526d98636ba32a463e 100644 (file)
@@ -1,6 +1,8 @@
 config BR2_PACKAGE_KODI_PVR_VUPLUS
        bool "kodi-pvr-vuplus"
+       select BR2_PACKAGE_JSON_FOR_MODERN_CPP
        select BR2_PACKAGE_KODI_PLATFORM
+       select BR2_PACKAGE_TINYXML
        help
          VuPlus PVR client addon for Kodi
 
index f4f6756931d60173a071b32501a6221b054c14bb..eb0408db8a81b410943be3225cb3ae0234937edc 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 a8c7345e4e2e415e29c21f14460b257dfbe08ed5ecf1cc2dc6bc393a10f95cf3  kodi-pvr-vuplus-2.4.12-Krypton.tar.gz
+sha256 d7dd890e4491e211ff3781cdc043347ab7a4ef6e00619ac1b4641ed81b0c3626  kodi-pvr-vuplus-3.28.9-Leia.tar.gz
index 581d884caa63d18857a3a369958937612f77cbbf..34ec5d23846266637f9440a5bb9fc1e3a10d99f4 100644 (file)
@@ -4,12 +4,10 @@
 #
 ################################################################################
 
-# This cset is on the branch 'Krypton'
-# When Kodi is updated, then this should be updated to the corresponding branch
-KODI_PVR_VUPLUS_VERSION = 2.4.12-Krypton
+KODI_PVR_VUPLUS_VERSION = 3.28.9-Leia
 KODI_PVR_VUPLUS_SITE = $(call github,kodi-pvr,pvr.vuplus,$(KODI_PVR_VUPLUS_VERSION))
 KODI_PVR_VUPLUS_LICENSE = GPL-2.0+
 KODI_PVR_VUPLUS_LICENSE_FILES = src/client.h
-KODI_PVR_VUPLUS_DEPENDENCIES = kodi-platform
+KODI_PVR_VUPLUS_DEPENDENCIES = json-for-modern-cpp kodi-platform tinyxml
 
 $(eval $(cmake-package))