package/libselinux: enable kernel selinux support for ext3 images
authorAdam Duskett <Aduskett@gmail.com>
Fri, 31 Jul 2020 20:40:55 +0000 (13:40 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 13:43:41 +0000 (15:43 +0200)
If BR2_TARGET_ROOTFS_EXT2_3 is selected, enable the following kernel options:
  - CONFIG_EXT3_FS_SECURITY

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libselinux/libselinux.mk

index 77efe2d8e0ca5fa3c063284ea363947fd32cf588..525f4fe9a2a95ecf309dc9851c9dca3d90a31139 100644 (file)
@@ -118,6 +118,8 @@ define LIBSELINUX_LINUX_CONFIG_FIXUPS
        $(if $(BR2_TARGET_ROOTFS_EXT2),
                $(call KCONFIG_ENABLE_OPT,CONFIG_EXT2_FS_XATTR)
                $(call KCONFIG_ENABLE_OPT,CONFIG_EXT2_FS_SECURITY))
+       $(if $(BR2_TARGET_ROOTFS_EXT2_3),
+               $(call KCONFIG_ENABLE_OPT,CONFIG_EXT3_FS_SECURITY))
 endef
 
 $(eval $(generic-package))