gpsd: enable kpps support
authorJames Knight <james.knight@rockwellcollins.com>
Fri, 27 Nov 2015 16:25:57 +0000 (11:25 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 28 Nov 2015 14:09:37 +0000 (15:09 +0100)
GPSD has the ability to support KPPS. Its enablement is determined
primarily from the existence of `sys/timepps.h`. This file is provided
from the pps-tools package. Adjusting GPSD's Makefile to depend on the
pps-tools package if a developer has included pps-tools as part of a
build.

Signed-off-by: James Knight <james.knight@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gpsd/gpsd.mk

index 87911c3905fe5669b1116d0d5858adfc888d9c4c..30554034b50dca43da1f380658957415ae82f4bc 100644 (file)
@@ -59,6 +59,12 @@ else
 GPSD_SCONS_OPTS += bluez=no
 endif
 
+# If pps-tools is available, build it before so the package can use it
+# (HAVE_SYS_TIMEPPS_H).
+ifeq ($(BR2_PACKAGE_PPS_TOOLS),y)
+GPSD_DEPENDENCIES += pps-tools
+endif
+
 ifeq ($(BR2_PACKAGE_DBUS_GLIB),y)
 GPSD_SCONS_OPTS += dbus_export=yes
 GPSD_DEPENDENCIES += dbus-glib