package/ncurses: add option to install extra terminfo files
authorCam Hutchison <camh@xdna.net>
Mon, 16 Oct 2017 01:13:51 +0000 (12:13 +1100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 6 Feb 2018 15:16:42 +0000 (16:16 +0100)
Add an option to ncurses to install extra user-configured terminfo
files. By default, only a small number of vital terminfo files are
installed on the target. This allows a build to specify the terminfo
files it needs.

Signed-off-by: Cam Hutchison <camh@xdna.net>
[Thomas: qstrip the variable before using it.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ncurses/Config.in
package/ncurses/ncurses.mk

index bb45bd8dc0e1f6de971145a2480067fcdd2268ec..297b2ee4150f9c6567e4270e415d5d7f373a6677 100644 (file)
@@ -23,4 +23,14 @@ config BR2_PACKAGE_NCURSES_TARGET_PROGS
        help
          Include ncurses programs in target (clear, reset, tput, ...)
 
+config BR2_PACKAGE_NCURSES_ADDITIONAL_TERMINFO
+       string "additional terminfo files to install"
+       help
+         Whitespace separated list of terminfo files to install on the
+         target. A small number of vital terminfo files are always
+         installed. This list is in addition to the vital ones.
+
+         The terminfo filenames should have the single letter path
+         prefix. e.g. t/tmux.
+
 endif
index 32ee0853142d8a9c5c69944bde0e90ad6c695706..eccfbecb8b5c7c86fe31cb13222af9e37743b392 100644 (file)
@@ -63,7 +63,8 @@ NCURSES_TERMINFO_FILES = \
        x/xterm+256color \
        x/xterm-256color \
        x/xterm-color \
-       x/xterm-xfree86
+       x/xterm-xfree86 \
+       $(call qstrip,$(BR2_PACKAGE_NCURSES_ADDITIONAL_TERMINFO))
 
 ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
 NCURSES_CONF_OPTS += --enable-widec