uboot: ensure u-boot-dtb.img gets built if enabled
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 2 May 2016 21:26:52 +0000 (23:26 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 5 May 2016 09:31:39 +0000 (11:31 +0200)
u-boot-dtb.img only gets built by default (all target) if
CONFIG_OF_SEPARATE _AND_ CONFIG_SPL_FRAMEWORK are enabled.

Certain SoCs (E.G. Action Semi S500) use a proprietary first level
bootloader instead of u-boot SPL, but still use u-boot-dtb.img as the first
level bootloader parses the uImage header for size/loadaddr.

Ensure u-boot-dtb.img gets built if enabled by explicitly listing it as a
u-boot make target (next to all) to support such setups.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/uboot/uboot.mk

index 48f40c3b6bf5ef3b935f30cbe5b1469210b975af..e071303f7cf27773461dd2c945dd3a82c0606c45 100644 (file)
@@ -50,6 +50,7 @@ else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)
 UBOOT_BIN = u-boot-nand.bin
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_DTB_IMG),y)
 UBOOT_BIN = u-boot-dtb.img
+UBOOT_MAKE_TARGET = all $(UBOOT_BIN)
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMG),y)
 UBOOT_BIN = u-boot.img
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMX),y)