package/libevent: drop patch
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 17 Aug 2019 19:32:08 +0000 (21:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 17 Aug 2019 22:19:24 +0000 (00:19 +0200)
Drop patch and autoreconf, instead use existing
--disable-libevent-regress option to disable tests

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libevent/0001-Disable-building-test-programs.patch [deleted file]
package/libevent/libevent.mk

diff --git a/package/libevent/0001-Disable-building-test-programs.patch b/package/libevent/0001-Disable-building-test-programs.patch
deleted file mode 100644 (file)
index cac05ec..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 4b5a135fa681e85eb6988a379f59f3c7a41cc48c Mon Sep 17 00:00:00 2001
-From: Gilles Talis <gilles.talis@gmail.com>
-Date: Fri, 21 Jun 2013 15:25:11 -0700
-Subject: [PATCH] Disable building test programs
-
-We are not really interested in building test programs.
-Moreover, these programs use fork() function that is
-not available on MMU-less architectures.
-
-Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
-[aduskett@gmail.com: Updated for 2.1.8]
-Signed-off-by: Adam Duskett <aduskett@gmail.com>
----
- Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index 42879a3..dc90359 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -144,7 +144,6 @@
- BUILT_SOURCES =
- include include/include.am
- include sample/include.am
--include test/include.am
- if BUILD_WIN32
--- 
-2.1.1
-
index f4d2a4c0abc828bb438453da353bbe57a435f817..a5ba7fdf6afe06c30ae6d5a84bed82a5a3500231 100644 (file)
@@ -10,10 +10,13 @@ LIBEVENT_SOURCE = libevent-$(LIBEVENT_VERSION)-stable.tar.gz
 LIBEVENT_INSTALL_STAGING = YES
 LIBEVENT_LICENSE = BSD-3-Clause, OpenBSD
 LIBEVENT_LICENSE_FILES = LICENSE
-# For 0001-Disable-building-test-programs.patch
-LIBEVENT_AUTORECONF = YES
-LIBEVENT_CONF_OPTS = --disable-samples
-HOST_LIBEVENT_CONF_OPTS = --disable-samples --disable-openssl
+LIBEVENT_CONF_OPTS = \
+       --disable-libevent-regress \
+       --disable-samples
+HOST_LIBEVENT_CONF_OPTS = \
+       --disable-libevent-regress \
+       --disable-samples \
+       --disable-openssl
 
 define LIBEVENT_REMOVE_PYSCRIPT
        rm $(TARGET_DIR)/usr/bin/event_rpcgen.py