flite: depend on alsa-lib when available
authorBaruch Siach <baruch@tkos.co.il>
Thu, 1 May 2014 03:17:27 +0000 (06:17 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 May 2014 20:30:45 +0000 (22:30 +0200)
The flite configure script detects the availability of alsa-lib. Add alsa-lib
to flite dependencies to make sure alsa-lib is always detected when
available.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/flite/flite.mk

index 7511b87731e7df05c0e81bfc65644a841688b52a..08d2ce1622f90befb4d36fe14dc6dbc5e8e5f1fe 100644 (file)
@@ -38,4 +38,11 @@ define FLITE_EXTRACT_CMDS
        $(RM) -rf $(BUILD_DIR)/$(subst .tar.bz2,,$(FLITE_SOURCE))
 endef
 
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+FLITE_DEPENDENCIES += alsa-lib
+FLITE_CONF_OPT += --with-audio=alsa
+else
+FLITE_CONF_OPT += --with-audio=oss
+endif
+
 $(eval $(autotools-package))