pkg-infra: also set PKGDIR for the download step
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 30 Jun 2014 22:26:20 +0000 (00:26 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Jul 2014 15:16:14 +0000 (17:16 +0200)
This will be needed to get the hash file, to check the
downloaded files.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-generic.mk

index 54193d25a22013ffe9a1045e94833c8590c1a678..ab1f8d2ca1e21880363d57c3f014ce6c1950e03c 100644 (file)
@@ -602,6 +602,7 @@ $$($(2)_TARGET_PATCH):                      RAWNAME=$$(patsubst host-%,%,$(1))
 $$($(2)_TARGET_PATCH):                 PKGDIR=$(pkgdir)
 $$($(2)_TARGET_EXTRACT):               PKG=$(2)
 $$($(2)_TARGET_SOURCE):                        PKG=$(2)
+$$($(2)_TARGET_SOURCE):                        PKGDIR=$(pkgdir)
 $$($(2)_TARGET_DIRCLEAN):              PKG=$(2)
 
 # Compute the name of the Kconfig option that correspond to the