package/aubio: add ffmpeg libav optional dependency
authorRomain Naour <romain.naour@gmail.com>
Sat, 3 Dec 2016 12:17:39 +0000 (13:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 15:22:13 +0000 (16:22 +0100)
Aubio libav support require libavcodec, libavformat, libavutil and
libavresample. Enable libav support only when
BR2_PACKAGE_FFMPEG_AVRESAMPLE is set.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/aubio/aubio.mk

index 9339f44957461a1528bc00ad1a492ab883b43ab2..cfa233f98958a5e57465c287833c710be6f4c907 100644 (file)
@@ -13,8 +13,7 @@ AUBIO_INSTALL_STAGING = YES
 
 AUBIO_CONF_OPTS = \
        --disable-docs \
-       --disable-atlas \
-       --disable-avcodec
+       --disable-atlas
 
 ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
 AUBIO_DEPENDENCIES += libsndfile
@@ -49,4 +48,11 @@ else  # !BR2_PACKAGE_FFTW
 AUBIO_CONF_OPTS += --disable-fftw3
 endif
 
+ifeq ($(BR2_PACKAGE_FFMPEG_AVRESAMPLE),y)
+AUBIO_DEPENDENCIES += ffmpeg
+AUBIO_CONF_OPTS += --enable-avcodec
+else
+AUBIO_CONF_OPTS += --disable-avcodec
+endif
+
 $(eval $(waf-package))