xxhash: new package
authorEd Swierk <eswierk@skyportsystems.com>
Thu, 16 Jul 2015 20:59:35 +0000 (13:59 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Sep 2015 13:52:40 +0000 (15:52 +0200)
"xxHash is an extremely fast hash algorithm, running at RAM speed
limits."

[Thomas:
 - tweak commit log title
 - add correct license and license files information, using the
   suggestion from Yann E. Morin
 - add $(TARGET_MAKE_ENV) in the environment in the build step.]

Signed-off-by: Ed Swierk <eswierk@skyportsystems.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/xxhash/Config.in [new file with mode: 0644]
package/xxhash/xxhash.mk [new file with mode: 0644]

index 1bd27592fd222c8b5da588e9a531f2e077ab198c..22aef52bf4c562fad951895fa69a223303dada93 100644 (file)
@@ -1458,6 +1458,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
        source "package/which/Config.in"
 endif
        source "package/xmlstarlet/Config.in"
+       source "package/xxhash/Config.in"
 endmenu
 
 menu "System tools"
diff --git a/package/xxhash/Config.in b/package/xxhash/Config.in
new file mode 100644 (file)
index 0000000..f2cccda
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_XXHASH
+       bool "xxhash"
+       help
+         xxHash is an extremely fast hash algorithm, running at RAM
+         speed limits.
+
+         https://github.com/Cyan4973/xxHash
diff --git a/package/xxhash/xxhash.mk b/package/xxhash/xxhash.mk
new file mode 100644 (file)
index 0000000..47ead75
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# xxhash
+#
+################################################################################
+
+XXHASH_VERSION = r40
+XXHASH_SITE = $(call github,Cyan4973,xxHash,$(XXHASH_VERSION))
+XXHASH_LICENSE = BSD-2c, GPLv2+
+XXHASH_LICENSE_FILES = LICENSE xxhsum.c
+
+define XXHASH_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) xxhsum
+endef
+
+define XXHASH_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/xxhsum $(TARGET_DIR)/usr/bin/xxhsum
+endef
+
+$(eval $(generic-package))