live555: fix shared library build on x86
authorBaruch Siach <baruch@tkos.co.il>
Tue, 2 Dec 2014 07:48:41 +0000 (09:48 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Dec 2014 11:57:18 +0000 (12:57 +0100)
-fPIC is required for shared libraries on x86.

Fixes:
http://autobuild.buildroot.net/results/6e7/6e78d3e29856c25d233f1629c31bc15f7ecb2f89/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/live555/live555.mk

index 7dbded3522cd8e997a32a828beb0d2b7b5f20c7d..064450546fc28af66c1c481a3dc029320da2ad07 100644 (file)
@@ -19,6 +19,7 @@ LIVE555_LIBRARY_LINK = $(TARGET_AR) cr
 else
 LIVE555_CONFIG_TARGET = linux-with-shared-libraries
 LIVE555_LIBRARY_LINK = $(TARGET_CC) -o
+LIVE555_CFLAGS += -fPIC
 endif
 
 ifndef ($(BR2_ENABLE_LOCALE),y)