lzo: build shared library for the host
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 21 Aug 2018 21:59:51 +0000 (23:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 22 Aug 2018 11:34:00 +0000 (13:34 +0200)
By default, the lzo package builds and installs only a static
library. For the target variant, we pass the appropriate
ENABLE_STATIC/ENABLE_SHARED options, but not for the host package, and
therefore a static lzo library gets installed.

However, on the host, our policy is to build shared libraries and not
static libraries, as visible in the default configure options passed
to host package in pkg-autotools.mk (--enable-shared
--disable-static). Let's do the same with lzo.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lzo/lzo.mk

index 27ca459acf32986c029ca25b39f1a9bb35a14049..0ead92725a6fa11e97038bb532cf4c78133882bc 100644 (file)
@@ -23,5 +23,7 @@ else
 LZO_CONF_OPTS += -DENABLE_STATIC=OFF
 endif
 
+HOST_LZO_CONF_OPTS += -DENABLE_SHARED=ON -DENABLE_STATIC=OFF
+
 $(eval $(cmake-package))
 $(eval $(host-cmake-package))