package/nginx: add support for slice module
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 21 Jun 2020 21:42:27 +0000 (23:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 22 Jun 2020 19:10:52 +0000 (21:10 +0200)
slice module is available since version 1.9.8 and
https://github.com/nginx/nginx/commit/8ba626ccd71cbd704c7c69928d1d6fe58fd0445f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nginx/Config.in
package/nginx/nginx.mk

index 0dbeaae2ffbb03565dbb8c43bf5828d5c76b070a..52711b1de30ff78bbdf015b3f536ef4f532d8f9d 100644 (file)
@@ -134,6 +134,11 @@ config BR2_PACKAGE_NGINX_HTTP_DEGRADATION_MODULE
        help
          Enable ngx_http_degradation_module
 
+config BR2_PACKAGE_NGINX_HTTP_SLICE_MODULE
+       bool "ngx_http_slice_module"
+       help
+         Enable ngx_http_slice_module
+
 config BR2_PACKAGE_NGINX_HTTP_STUB_STATUS_MODULE
        bool "ngx_http_stub_status_module"
        help
index 3f249096bc901edee8c9246fa39dd32a4b471a16..81708fd32f05eb7496e466b3cfe7a5b8f4952285 100644 (file)
@@ -175,6 +175,7 @@ NGINX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_NGINX_HTTP_AUTH_REQUEST_MODULE),--with-http_auth_request_module) \
        $(if $(BR2_PACKAGE_NGINX_HTTP_RANDOM_INDEX_MODULE),--with-http_random_index_module) \
        $(if $(BR2_PACKAGE_NGINX_HTTP_DEGRADATION_MODULE),--with-http_degradation_module) \
+       $(if $(BR2_PACKAGE_NGINX_HTTP_SLICE_MODULE),--with-http_slice_module) \
        $(if $(BR2_PACKAGE_NGINX_HTTP_STUB_STATUS_MODULE),--with-http_stub_status_module) \
        $(if $(BR2_PACKAGE_NGINX_HTTP_CHARSET_MODULE),,--without-http_charset_module) \
        $(if $(BR2_PACKAGE_NGINX_HTTP_SSI_MODULE),,--without-http_ssi_module) \