package/swupdate: default website have a new API
authorJulien Corjon <corjon.j@ecagroup.com>
Mon, 16 Apr 2018 13:20:35 +0000 (15:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 16 Apr 2018 14:21:06 +0000 (16:21 +0200)
2018.03 introduce a new website with Websocket asynchronous
communication[1]

[1] https://github.com/sbabic/swupdate/blob/master/doc/source/mongoose.rst

Signed-off-by: Julien Corjon <corjon.j@ecagroup.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/swupdate/swupdate.mk

index 8649931eb79919ab023cfa7b8b7b5b0c3c8c571b..abf46c9256406fc440b61ed3deda3f98e41cc3d7 100644 (file)
@@ -125,7 +125,7 @@ define SWUPDATE_INSTALL_TARGET_CMDS
        $(INSTALL) -D -m 0755 $(@D)/swupdate $(TARGET_DIR)/usr/bin/swupdate
        $(if $(BR2_PACKAGE_SWUPDATE_INSTALL_WEBSITE), \
                mkdir -p $(TARGET_DIR)/var/www/swupdate; \
-               cp -dpf $(@D)/www/* $(TARGET_DIR)/var/www/swupdate)
+               cp -dpfr $(@D)/examples/www/v2/* $(TARGET_DIR)/var/www/swupdate)
 endef
 
 # Checks to give errors that the user can understand