libump: new package
authorFrancois Perrad <fperrad@gmail.com>
Fri, 26 Jun 2015 08:13:36 +0000 (10:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Jun 2015 13:18:04 +0000 (15:18 +0200)
previously, this library was a part of sunxi-mali

[Thomas: add missing comment about the glibc dependency.]

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libump/Config.in [new file with mode: 0644]
package/libump/libump.mk [new file with mode: 0644]

index 9dbc98fb7f13f0a4cbfd7ca2d3f5de593505e5a0..c2f6524eb586ba5ef42eec9b26a78be2bce5e9b7 100644 (file)
@@ -367,6 +367,7 @@ endif
        source "package/iucode-tool/Config.in"
        source "package/kbd/Config.in"
        source "package/lcdproc/Config.in"
+       source "package/libump/Config.in"
        source "package/lirc-tools/Config.in"
        source "package/lm-sensors/Config.in"
        source "package/lshw/Config.in"
diff --git a/package/libump/Config.in b/package/libump/Config.in
new file mode 100644 (file)
index 0000000..10232b3
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBUMP
+       bool "libump"
+       depends on BR2_TOOLCHAIN_USES_GLIBC
+       depends on BR2_arm
+       help
+         The ARMs Universal Memory Provider userspace library.
+         This library is a requirement for ARMs binary Mali driver.
+
+         http://github.com/linux-sunxi/libump
+
+comment "libump needs a (e)glibc toolchain"
+       depends on BR2_arm
+       depends on !BR2_TOOLCHAIN_USES_GLIBC
diff --git a/package/libump/libump.mk b/package/libump/libump.mk
new file mode 100644 (file)
index 0000000..65012ff
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# libump
+#
+################################################################################
+
+LIBUMP_VERSION = ec0680628744f30b8fac35e41a7bd8e23e59c39f
+LIBUMP_SITE = $(call github,linux-sunxi,libump,$(LIBUMP_VERSION))
+LIBUMP_LICENSE = Apache-2.0
+LIBUMP_AUTORECONF = YES
+LIBUMP_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))