netcat: add forced dependence on BusyBox
authorCarlos Santos <casantos@datacom.ind.br>
Thu, 12 Oct 2017 15:14:18 +0000 (12:14 -0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 31 Mar 2018 22:18:06 +0000 (00:18 +0200)
It may be necessary if packages become built in parallel, leading to a
race condition on the creation of the "nc" link.

Of course this still leaves a race conditon if other netcat competitors
but we must assume thet the user is a grown-up person who knows what is
doing.

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
[Arnout: Don't force-remove the existing nc, not needed according to
         Romain.]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/netcat/netcat.mk

index eb7ddcac2727b484b78877e6dae50ba4d3654c57..6c7c4b8f299bf1b67ca43ce127a32a2c5b51939a 100644 (file)
@@ -9,4 +9,10 @@ NETCAT_SITE = http://downloads.sourceforge.net/project/netcat/netcat/$(NETCAT_VE
 NETCAT_LICENSE = GPL-2.0+
 NETCAT_LICENSE_FILES = COPYING
 
+# Ensure Busybox gets built/installed before, so that this package overrides
+# Busybox nc.
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+NETCAT_DEPENDENCIES += busybox
+endif
+
 $(eval $(autotools-package))