package/python-bluezero: new package
authorGrzegorz Blach <grzegorz@blach.pl>
Thu, 26 Sep 2019 19:27:18 +0000 (19:27 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 27 Sep 2019 20:27:29 +0000 (22:27 +0200)
Python library for Bluetooth Low Energy (BLE) on Linux.

Signed-off-by: Grzegorz Blach <grzegorz@blach.pl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-bluezero/Config.in [new file with mode: 0644]
package/python-bluezero/python-bluezero.hash [new file with mode: 0644]
package/python-bluezero/python-bluezero.mk [new file with mode: 0644]

index 2764b2422b3ddc9babce9645aeebbb93c3c42032..d94c1e06f903c86983257e6fa79f27e90a30e662 100644 (file)
@@ -987,6 +987,7 @@ F:  package/bluez5_utils-headers/
 F:     package/f2fs-tools/
 F:     package/pigpio/
 F:     package/python-aioblescan/
+F:     package/python-bluezero/
 F:     package/python-falcon/
 F:     package/python-ifaddr/
 F:     package/python-hiredis/
index 10b441c6e1a7f6b7a660ba401812a48b7a413bac..d3f09d45c1f0671956960d82fbcdb629a396c9a5 100644 (file)
@@ -842,6 +842,7 @@ menu "External python modules"
        source "package/python-bcrypt/Config.in"
        source "package/python-beautifulsoup4/Config.in"
        source "package/python-bitstring/Config.in"
+       source "package/python-bluezero/Config.in"
        source "package/python-bottle/Config.in"
        source "package/python-brotli/Config.in"
        source "package/python-cached-property/Config.in"
diff --git a/package/python-bluezero/Config.in b/package/python-bluezero/Config.in
new file mode 100644 (file)
index 0000000..ed2277d
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PYTHON_BLUEZERO
+       bool "python-bluezero"
+       help
+         Python library for Bluetooth Low Energy (BLE) on Linux.
+
+         For central.py, peripheral.py and broadcaster.py you need
+         to enable the dbus-python and the bluez5-utils package.
+         For observer.py, you need to enable the python-aioblescan
+         package.
+
+         https://github.com/ukBaz/python-bluezero
diff --git a/package/python-bluezero/python-bluezero.hash b/package/python-bluezero/python-bluezero.hash
new file mode 100644 (file)
index 0000000..e1adcf5
--- /dev/null
@@ -0,0 +1,3 @@
+# md5, sha256 from https://pypi.org/pypi/bluezero/json
+md5    b13fd84a5fe98ce9526a6f513c9131b1  bluezero-0.2.0.tar.gz
+sha256 d16eb9ac048665a974ad0db312b23bfd528423000b7b2983566b853d5e0d19b6  bluezero-0.2.0.tar.gz
diff --git a/package/python-bluezero/python-bluezero.mk b/package/python-bluezero/python-bluezero.mk
new file mode 100644 (file)
index 0000000..1271b99
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-bluezero
+#
+################################################################################
+
+PYTHON_BLUEZERO_VERSION = 0.2.0
+PYTHON_BLUEZERO_SOURCE = bluezero-$(PYTHON_BLUEZERO_VERSION).tar.gz
+PYTHON_BLUEZERO_SITE = https://files.pythonhosted.org/packages/9c/76/8f5250e119be8aff4f7ac3acb9d91589909d8650152fdf6758bfb01f9576
+PYTHON_BLUEZERO_SETUP_TYPE = setuptools
+PYTHON_BLUEZERO_LICENSE = MIT
+
+$(eval $(python-package))