package/systemd: add option to enable systemd-journal-remote
authorYi Zheng <goodmenzy@gmail.com>
Thu, 13 Jun 2019 03:05:27 +0000 (11:05 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 17 Jun 2019 19:28:36 +0000 (21:28 +0200)
systemd-journal-remote was added in systemd v211, so add a new option
to enable or disable it.

Signed-off-by: Yi Zheng <goodmenzy@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 92ffc7cc5a4b4babbdd81a635fbb9d6eec202bbe..ad72a269efb26089fd9f10cf2430b14537db0f73 100644 (file)
@@ -122,6 +122,20 @@ config BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY
 
          http://www.freedesktop.org/software/systemd/man/systemd-journal-gatewayd.service.html
 
+config BR2_PACKAGE_SYSTEMD_JOURNAL_REMOTE
+       bool "enable systemd-journal-remote"
+       depends on BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY
+       select BR2_PACKAGE_LIBCURL
+       help
+         systemd-journal-remote is a command to receive serialized
+         journal events and store them to journal files. Input
+         streams are in the Journal Export Format[1], i.e. like the
+         output from journalctl --output=export. For transport over
+         the network, this serialized stream is usually carried over
+         an HTTPS connection.
+
+         https://www.freedesktop.org/software/systemd/man/systemd-journal-remote.service.html
+
 config BR2_PACKAGE_SYSTEMD_BACKLIGHT
        bool "enable backlight support"
        help
index edc4a9ecc123d5261fea48ab7e788dc8a66bc5f4..e8fd7967bded31e886602f733669e794321ddde1 100644 (file)
@@ -178,6 +178,12 @@ else
 SYSTEMD_CONF_OPTS += -Dmicrohttpd=false -Dqrencode=false
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_REMOTE),y)
+SYSTEMD_CONF_OPTS += -Dremote=true
+else
+SYSTEMD_CONF_OPTS += -Dremote=false
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
 SYSTEMD_DEPENDENCIES += libselinux
 SYSTEMD_CONF_OPTS += -Dselinux=true