chrony: disable docs build
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 1 Sep 2014 19:25:17 +0000 (16:25 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Sep 2014 20:11:35 +0000 (22:11 +0200)
Needs makeinfo and we don't care about docs. Fixes:
http://autobuild.buildroot.net/results/fd0/fd03a86ed670c765d9f0a1ed6cc913079e030fc9/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/chrony/chrony.mk

index 59e5bfcb4815f3c0faa4c71518c40d6cfe004a42..4fdb81f9798991c67ff5635d8c2fd1b13e625cd0 100644 (file)
@@ -27,6 +27,12 @@ ifneq ($(BR2_INET_IPV6),y)
 CHRONY_CONF_OPT += --disable-ipv6
 endif
 
+# Ditch the doc build, needs makeinfo and we don't need them
+define CHRONY_DISABLE_DOCS
+       $(SED) 's/chronyc chrony.txt/chronyc/' $(@D)/Makefile.in
+endef
+CHRONY_POST_PATCH_HOOKS += CHRONY_DISABLE_DOCS
+
 define CHRONY_CONFIGURE_CMDS
        cd $(@D) && $(TARGET_CONFIGURE_OPTS) ./configure $(CHRONY_CONF_OPT)
 endef