gcc/gcc-final: pass TARGET_ABI flags to configure with --enable-cxx-flags
authorMax Filippov <jcmvbkbc@gmail.com>
Tue, 26 May 2015 07:32:36 +0000 (10:32 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 May 2015 20:51:21 +0000 (22:51 +0200)
libstdc++ is in all regards a normal library, it needs to be built with
TARGET_ABI flags, otherwise linking it with other C++ code may fail.

Pass TARGET_ABI flags to gcc-final configure script in the
--enable-cxx-flags parameter.

Fixes:
  http://autobuild.buildroot.net/results/81a3bca5cbcf789c7ce1aa221a6a4154dd7c3917/
  http://autobuild.buildroot.net/results/4943b214c29951ecc7af0a1f360b6454485c0b9b/

Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/gcc-final/gcc-final.mk

index d873aa65b08c798b42c2246329447522f51c21b7..8d7009bbad07814ca57e8fe64af65dd1d02d7ed9 100644 (file)
@@ -185,4 +185,8 @@ endef
 HOST_GCC_FINAL_POST_INSTALL_HOOKS += HOST_GCC_FINAL_INSTALL_USR_LIBS
 endif
 
+ifeq ($(BR2_xtensa),y)
+HOST_GCC_FINAL_CONF_OPTS += --enable-cxx-flags="$(TARGET_ABI)"
+endif
+
 $(eval $(host-autotools-package))