package/mesa3d: Refactor XA support to prepare support for ATI drivers
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 17 Jan 2015 17:03:54 +0000 (18:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 2 Feb 2015 20:39:15 +0000 (21:39 +0100)
[Thomas:
  - move the new blind option next to the other existing blind options
    in the package.
  - edit the commit log to remove the changelog.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/Config.in
package/mesa3d/mesa3d.mk

index eb977b6510119b662207bafb53d746e8853d2322..d8ee8c2e151a6fc0a72b7002d8ef623223b13578 100644 (file)
@@ -36,6 +36,9 @@ config BR2_PACKAGE_PROVIDES_LIBGL
 config BR2_PACKAGE_MESA3D_DRIVER
        bool
 
+config BR2_PACKAGE_MESA3D_NEEDS_XA
+       bool
+
 comment "Gallium drivers"
 
 config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU
@@ -43,6 +46,7 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU
        depends on BR2_i386 || BR2_x86_64
        select BR2_PACKAGE_MESA3D_GALLIUM_DRIVER
        select BR2_PACKAGE_LIBDRM_NOUVEAU
+       select BR2_PACKAGE_MESA3D_NEEDS_XA
        help
          Supports all Nvidia GPUs.
 
@@ -51,6 +55,7 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SVGA
        depends on BR2_i386 || BR2_x86_64
        select BR2_PACKAGE_MESA3D_GALLIUM_DRIVER
        select BR2_PACKAGE_LIBDRM_VMWGFX
+       select BR2_PACKAGE_MESA3D_NEEDS_XA
        help
          This is a virtual GPU driver for VMWare virtual machines.
 
index 3d780f9e925405e8096fc98d973453bf4a942d5e..4ff7e094c5dcbba0f01f0e87ae69b4f3c86b34d2 100644 (file)
@@ -36,7 +36,7 @@ MESA3D_DEPENDENCIES += \
        libxcb
 MESA3D_CONF_OPTS += --enable-glx
 # quote from mesa3d configure "Building xa requires at least one non swrast gallium driver."
-ifneq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU)$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SVGA),)
+ifneq ($(BR2_PACKAGE_MESA3D_NEEDS_XA),)
 MESA3D_CONF_OPTS += --enable-xa
 else
 MESA3D_CONF_OPTS += --disable-xa