package/opencv4: do not detect ccache
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Aug 2021 21:53:57 +0000 (23:53 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Aug 2021 15:45:33 +0000 (17:45 +0200)
OpenCV-4's buildsystem will try to detect ccache and use it if
available. This may yield a system-installed ccache.

However, in Buildroot, ccache is entirely hidden away and handled in the
toolchain wrapper.

Forcibly disable detection of ccache.

Commit 505e7f47715c77d8586444a4fefe4a190b77aaad already applied this
change to opencv3.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/opencv4/opencv4.mk

index 3cc6c0576910be93d47b1a78ba2ff62898799de1..040fc63e4e2a2432fe676fb3c12e37dd61b6d7c5 100644 (file)
@@ -49,6 +49,7 @@ endif
 # OpenCV build options
 OPENCV4_CONF_OPTS += \
        -DBUILD_WITH_STATIC_CRT=OFF \
+       -DENABLE_CCACHE=OFF \
        -DENABLE_COVERAGE=OFF \
        -DENABLE_FAST_MATH=ON \
        -DENABLE_IMPL_COLLECTION=OFF \