- SH endian setting (fgretief in bug #1446)
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 21 Aug 2007 08:05:40 +0000 (08:05 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 21 Aug 2007 08:05:40 +0000 (08:05 -0000)
toolchain/uClibc/uclibc.mk

index d026668b53e68b2996f26328ea67cbdafc1fbb74..c97219b676fb546c7878795f8c1bc0a478e97766 100644 (file)
@@ -73,6 +73,8 @@ UCLIBC_TARGET_ENDIAN:=$(shell $(SHELL) -c "echo $(ARCH) | sed \
                -e 's/arm/LITTLE/' \
                -e 's/mipsel/LITTLE/' \
                -e 's/mips/BIG/' \
+               -e 's/sh[234]eb/BIG/' \
+               -e 's/sh[234]/LITTLE/' \
 ")
 
 ifneq ($(UCLIBC_TARGET_ENDIAN),LITTLE)