jemalloc: bump version to 4.5.0
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Sun, 2 Apr 2017 17:54:18 +0000 (19:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 7 Apr 2017 17:44:21 +0000 (19:44 +0200)
Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
[Thomas: use release tarball, which avoids the need for autoreconf.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/jemalloc/0001-Disable-documentation.patch [new file with mode: 0644]
package/jemalloc/0001-Fix-LG_QUANTUM-definition-for-sparc64.patch [deleted file]
package/jemalloc/Config.in
package/jemalloc/jemalloc.hash
package/jemalloc/jemalloc.mk

diff --git a/package/jemalloc/0001-Disable-documentation.patch b/package/jemalloc/0001-Disable-documentation.patch
new file mode 100644 (file)
index 0000000..a5f252c
--- /dev/null
@@ -0,0 +1,29 @@
+From b9113f8dc939dab775dbc64bae03b927f0679467 Mon Sep 17 00:00:00 2001
+From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Date: Sun, 2 Apr 2017 19:26:04 +0200
+Subject: [PATCH] Disable documentation
+
+As there is no option to disable documentation, update Makefile.in to
+skip it.
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index e49a871..74a7541 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -383,7 +383,7 @@ done
+ install_doc: install_doc_html install_doc_man
+-install: install_bin install_include install_lib install_doc
++install: install_bin install_include install_lib
+ tests_unit: $(TESTS_UNIT:$(srcroot)%.c=$(objroot)%$(EXE))
+ tests_integration: $(TESTS_INTEGRATION:$(srcroot)%.c=$(objroot)%$(EXE))
+-- 
+2.9.3
+
diff --git a/package/jemalloc/0001-Fix-LG_QUANTUM-definition-for-sparc64.patch b/package/jemalloc/0001-Fix-LG_QUANTUM-definition-for-sparc64.patch
deleted file mode 100644 (file)
index ef5b857..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From b3211bd6363ee6884c8db64008dc325a9c711bfb Mon Sep 17 00:00:00 2001
-From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-Date: Thu, 14 Jul 2016 22:44:01 +0200
-Subject: [PATCH] Fix LG_QUANTUM definition for sparc64
-
-GCC 4.9.3 cross-compiled for sparc64 defines __sparc_v9__, not
-__sparc64__ nor __sparcv9. This prevents LG_QUANTUM from being defined
-properly. Adding this new value to the check solves the issue.
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
----
- include/jemalloc/internal/jemalloc_internal.h.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/jemalloc/internal/jemalloc_internal.h.in b/include/jemalloc/internal/jemalloc_internal.h.in
-index 51bf897..ece15b2 100644
---- a/include/jemalloc/internal/jemalloc_internal.h.in
-+++ b/include/jemalloc/internal/jemalloc_internal.h.in
-@@ -234,7 +234,7 @@ typedef unsigned szind_t;
- #  ifdef __alpha__
- #    define LG_QUANTUM                4
- #  endif
--#  if (defined(__sparc64__) || defined(__sparcv9))
-+#  if (defined(__sparc64__) || defined(__sparcv9) || defined(__sparc_v9__))
- #    define LG_QUANTUM                4
- #  endif
- #  if (defined(__amd64__) || defined(__x86_64__) || defined(_M_X64))
--- 
-2.4.11
-
index b1b92bb7c5fec41e7c5f4a49448ac4c3054183aa..85861407daf484731397634a8bf58fad1ab66fd8 100644 (file)
@@ -17,7 +17,7 @@ config BR2_PACKAGE_JEMALLOC
          This library providing a malloc(3) implementation that emphasizes
          fragmentation avoidance and scalable concurrency support.
 
-         http://www.canonware.com/jemalloc/
+         http://jemalloc.net/
 
 comment "jemalloc needs a toolchain w/ dynamic library, threads"
        depends on BR2_PACKAGE_JEMALLOC_ARCH_SUPPORTS
index b6c860baa628eebdf232b28dca459bfd320289e9..65dbecc530172ae8614a2a4a780b02496fe74a81 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 5630650d5c1caab95d2f0898de4fe5ab8519dc680b04963b38bb425ef6a42d57 jemalloc-4.2.1.tar.bz2
+sha256 9409d85664b4f135b77518b0b118c549009dc10f6cba14557d170476611f6780  jemalloc-4.5.0.tar.bz2
index 975d3196f85f941273b01edc9f0c26facf746d8a..17a3c9aad9b24139f8f33dbcf37af5802a44e5d6 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-JEMALLOC_VERSION = 4.2.1
+JEMALLOC_VERSION = 4.5.0
 JEMALLOC_SOURCE = jemalloc-$(JEMALLOC_VERSION).tar.bz2
-JEMALLOC_SITE = http://www.canonware.com/download/jemalloc
+JEMALLOC_SITE = https://github.com/jemalloc/jemalloc/releases/download/$(JEMALLOC_VERSION)
 JEMALLOC_LICENSE = BSD-2-Clause
 JEMALLOC_LICENSE_FILES = COPYING
 JEMALLOC_INSTALL_STAGING = YES