rpi-userland: add bcm_host to egl.pc
authorFloris Bos <bos@je-eigen-domein.nl>
Thu, 7 Mar 2013 10:18:33 +0000 (10:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 9 Mar 2013 21:25:41 +0000 (22:25 +0100)
bcm_host is the Broadcom hardware interface library
And is currently a dependency to use the EGL functions

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/rpi-userland/rpi-userland-add-pkgconfig-files.patch

index 0da9afd89baf5e5050b10b22d47a03616ee4f238..4ffc2b0bb6d3cd381762b29748dfb12c856e38b8 100644 (file)
@@ -9,7 +9,7 @@ Index: b/interface/khronos/egl/egl.pc.in
 ===================================================================
 --- /dev/null
 +++ b/interface/khronos/egl/egl.pc.in
-@@ -0,0 +1,10 @@
+@@ -0,0 +1,11 @@
 +prefix=@CMAKE_INSTALL_PREFIX@
 +exec_prefix=${prefix}
 +libdir=${exec_prefix}/lib
@@ -18,8 +18,9 @@ Index: b/interface/khronos/egl/egl.pc.in
 +Name: egl
 +Description: RasberryPi implementation of EGL
 +Version: 1.0
-+Libs: -L${libdir} -lEGL -lGLESv2
-+Cflags: -I${includedir}/ -I${includedir}/interface/vcos/pthreads/
++Libs: -L${libdir} -lEGL -lGLESv2 -lbcm_host
++Cflags: -I${includedir}/ -I${includedir}/interface/vcos/pthreads/ \
++        -I${includedir}/interface/vmcs_host/linux/
 Index: b/interface/khronos/CMakeLists.txt
 ===================================================================
 --- a/interface/khronos/CMakeLists.txt