netplug: properly install init.d script.
authorPeter Sanford <psanford@nearbuysystems.com>
Tue, 3 Sep 2013 17:22:54 +0000 (10:22 -0700)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 Sep 2013 22:16:50 +0000 (00:16 +0200)
Looks like this was lost in 20d4792e.

[Peter: use _INSTALL_INIT_SYSV, explicitly delete script on uninstall]
Signed-off-by: Peter Sanford <psanford@nearbuysystems.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/netplug/netplug.mk

index fbc7a2d98229fb387dfd2cfa4f132e8af8caebae..fdb1937b3a7868fe51cd12c11292637e006eadc5 100644 (file)
@@ -16,10 +16,15 @@ define NETPLUG_INSTALL_TARGET_CMDS
        $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
 endef
 
+define NETPLUG_INSTALL_INIT_SYSV
+       $(INSTALL) -m 0755 -D package/netplug/S29netplug \
+               $(TARGET_DIR)/etc/init.d/S29netplug
+endef
+
 define NETPLUG_UNINSTALL_TARGET_CMDS
        rm -f $(TARGET_DIR)/sbin/netplugd
        rm -rf $(TARGET_DIR)/etc/netplug*
-       rm -f $(TARGET_DIR)/etc/init.d/S*netplug
+       rm -f $(TARGET_DIR)/etc/init.d/S29netplug
 endef
 
 define NETPLUG_CLEAN_CMDS