package/uboot: define help commands when using Kconfig
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 1 Nov 2016 09:18:08 +0000 (10:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Nov 2016 13:51:15 +0000 (14:51 +0100)
Expose the Kconfig-related help commands when U-Boot uses the Kconfig
configuration. Like others (like Linux, barebox, busybox), only expose
menuconfig, not all the configurators.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/uboot/uboot.mk

index ae7539d512a625c8093fad2911937460f2957d9a..3e347c108429abafcd14973a3cae7e0be597b9b1 100644 (file)
@@ -181,6 +181,12 @@ endif # BR2_TARGET_UBOOT_USE_DEFCONFIG
 
 UBOOT_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
 UBOOT_KCONFIG_OPTS = $(UBOOT_MAKE_OPTS)
+define UBOOT_HELP_CMDS
+       @echo '  uboot-menuconfig       - Run U-Boot menuconfig'
+       @echo '  uboot-savedefconfig    - Run U-Boot savedefconfig'
+       @echo '  uboot-update-defconfig - Save the U-Boot configuration to the path specified'
+       @echo '                             by BR2_TARGET_UBOOT_CUSTOM_CONFIG_FILE'
+endef
 endif # BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY
 
 define UBOOT_BUILD_CMDS