Fixup a couple of thinko. Use the specified kernel compiler when compiling
authorEric Andersen <andersen@codepoet.org>
Thu, 5 Jun 2003 02:35:46 +0000 (02:35 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 5 Jun 2003 02:35:46 +0000 (02:35 -0000)
pcmcia modules.  And use the correct kernel source.

make/pcmcia.mk

index 187ea3ee3ef50540474535f65853fd509bde08c7..ced89f2a7bebb218823baacfe66efad10d4e9d02 100644 (file)
@@ -41,9 +41,9 @@ $(PCMCIA_DIR)/.patched: $(PCMCIA_DIR)/.unpacked
        touch $(PCMCIA_DIR)/.patched
 
 $(PCMCIA_DIR)/.configured: $(PCMCIA_DIR)/.patched
-       ( cd $(PCMCIA_DIR) ; ./Configure --kernel=$(LINUX_DIR) --noprompt \
+       ( cd $(PCMCIA_DIR) ; ./Configure --kernel=$(LINUX_SOURCE_DIR) --noprompt \
                --rcdir=/etc --arch=$(ARCH) --trust --srctree --nocardbus \
-               --sysv --kcc=$(HOSTCC) --ucc=$(TARGET_CC) --ld=$(TARGET_CROSS)ld \
+               --sysv --kcc=$(KERNEL_CROSS)gcc --ucc=$(TARGET_CC) --ld=$(TARGET_CROSS)ld \
                --target=$(TARGET_DIR))
        perl -i -p -e "s/pump/udhcpc/" $(PCMCIA_DIR)/etc/network
        perl -i -p -e "s/ide_cs/ide-cs/" $(PCMCIA_DIR)/etc/config