toolchain-external: update musl-cross toolchain to 1.1.6
authorWill Wagner <will_wagner@carallon.com>
Thu, 23 Apr 2015 13:27:10 +0000 (14:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Apr 2015 15:15:44 +0000 (17:15 +0200)
The 1.1.6 version of musl-cross fixes the two issues that had been
preventing versions after 1.1.1 being used by buildroot, namely:
- sysroot is enabled again
- kernel headers are included again

Signed-off-by: Will Wagner <will_wagner@carallon.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/toolchain-external.mk

index d2b99cc3e5b70c0e7d1c4edb4d1a75ad20050e05..9433101ada6d4b43fb8afb67b74fba51c43773d6 100644 (file)
@@ -814,7 +814,7 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_AARCH64
          glibc 2.18, gdb 7.7.50 and kernel headers 3.13.
 
 config BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS
-       bool "Musl 1.1.1 toolchain"
+       bool "Musl 1.1.6 toolchain"
        depends on (BR2_arm && BR2_ARM_EABI) || (BR2_armeb && BR2_ARM_EABI) || \
                (BR2_i386 && !BR2_x86_i386) || BR2_microblazebe || BR2_mips || \
                BR2_mipsel || (BR2_powerpc && BR2_powerpc_CLASSIC) || BR2_x86_64
@@ -825,8 +825,8 @@ config BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS
        select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
        help
          Toolchain based on the Musl C library, provided by the
-         musl-cross project. It uses gcc 4.8.3, binutils 2.24 and
-         musl 1.1.1. It does not have a cross debugger included.
+         musl-cross project. It uses gcc 4.9.2, binutils 2.25 and
+         musl 1.1.6. It does not have a cross debugger included.
 
          The ARM toolchain is built for ARMv4t, soft-float.
          The x86 toolchain is built for i486.
index 24274638539b94ebff48dfb66e1e1117b3065504..11345cc47ffc660eccc0a23886f693cc2d389cbb 100644 (file)
@@ -356,7 +356,7 @@ else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_AARCH64),y)
 TOOLCHAIN_EXTERNAL_SITE = http://sourcery.mentor.com/public/gnu_toolchain/aarch64-linux-gnu
 TOOLCHAIN_EXTERNAL_SOURCE = aarch64-2014.05-30-aarch64-linux-gnu-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS),y)
-TOOLCHAIN_EXTERNAL_VERSION = 1.1.1
+TOOLCHAIN_EXTERNAL_VERSION = 1.1.6
 TOOLCHAIN_EXTERNAL_SITE = https://googledrive.com/host/0BwnS5DMB0YQ6bDhPZkpOYVFhbk0/musl-$(TOOLCHAIN_EXTERNAL_VERSION)
 ifeq ($(BR2_arm),y)
 TOOLCHAIN_EXTERNAL_SOURCE = crossx86-arm-linux-musleabi-$(TOOLCHAIN_EXTERNAL_VERSION).tar.xz