package/spandsp: new package
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Oct 2018 13:13:57 +0000 (15:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 9 Oct 2018 13:11:09 +0000 (15:11 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[Bernd:
 - bumped version to 20180108
 - removed 0001-fix-msse4.x.patch, applied upstream
 - removed autoreconf after patch removal
 - added license hash (Arnout)
 - added SPDX license codes (Arnout)]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas:
 - add entry to DEVELOPERS file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/spandsp/Config.in [new file with mode: 0644]
package/spandsp/spandsp.hash [new file with mode: 0644]
package/spandsp/spandsp.mk [new file with mode: 0644]

index b54d3a9bc222d4f332b32e13a65fbca951ac2a2c..54bc1b8616a22600366336c60a2f8374f0616122 100644 (file)
@@ -405,6 +405,7 @@ F:  package/python-slob/
 F:     package/rtmpdump/
 F:     package/samba4/
 F:     package/softether/
+F:     package/spandsp/
 F:     package/sqlite/
 F:     package/taglib/
 F:     package/tinyxml2/
index 700afea6886ff94a36af272968f059483dd23aeb..1f1158a79ce70e58eeaae98b5cd06f4e2a751efe 100644 (file)
@@ -1111,6 +1111,7 @@ menu "Audio/Sound"
        source "package/opusfile/Config.in"
        source "package/portaudio/Config.in"
        source "package/sbc/Config.in"
+       source "package/spandsp/Config.in"
        source "package/speex/Config.in"
        source "package/speexdsp/Config.in"
        source "package/taglib/Config.in"
diff --git a/package/spandsp/Config.in b/package/spandsp/Config.in
new file mode 100644 (file)
index 0000000..a2d5b85
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SPANDSP
+       bool "spandsp"
+       select BR2_PACKAGE_TIFF
+       help
+         Spandsp is a library of many DSP functions for telephony.
+         These range from simple modules, such as DTMF detection, to
+         a complete software FAX machine.
+
+         http://www.soft-switch.org/
diff --git a/package/spandsp/spandsp.hash b/package/spandsp/spandsp.hash
new file mode 100644 (file)
index 0000000..1123e29
--- /dev/null
@@ -0,0 +1,3 @@
+# sha256 locally computed
+sha256 0fcdda74bd9703dd66c3e9721bf2d81bd7c185c539d1887768c2b332ab703d51  spandsp-20180108.tar.gz
+sha256 366576cb0b869cd9e95a4882878607314650488ac635e5df0692180382e9666a  COPYING
diff --git a/package/spandsp/spandsp.mk b/package/spandsp/spandsp.mk
new file mode 100644 (file)
index 0000000..4b1f89c
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# spandsp
+#
+################################################################################
+
+SPANDSP_VERSION = 20180108
+SPANDSP_SITE = https://www.soft-switch.org/downloads/spandsp/snapshots
+
+SPANDSP_LICENSE = LGPL-2.1 (library), GPL-2.0 (test suite)
+SPANDSP_LICENSE_FILES = COPYING
+
+SPANDSP_DEPENDENCIES = tiff
+SPANDSP_INSTALL_STAGING = YES
+
+SPANDSP_CONF_OPTS = \
+       --disable-doc \
+       --disable-builtin-tiff \
+       $(if $(BR2_X86_CPU_HAS_MMX),--enable-mmx,--disable-mmx) \
+       $(if $(BR2_X86_CPU_HAS_SSE),--enable-sse,--disable-sse) \
+       $(if $(BR2_X86_CPU_HAS_SSE2),--enable-sse2,--disable-sse2) \
+       $(if $(BR2_X86_CPU_HAS_SSE3),--enable-sse3,--disable-sse3) \
+       $(if $(BR2_X86_CPU_HAS_SSSE3),--enable-ssse3,--disable-ssse3) \
+       $(if $(BR2_X86_CPU_HAS_SSE4),--enable-sse4-1,--disable-sse4-1) \
+       $(if $(BR2_X86_CPU_HAS_SSE42),--enable-sse4-2,--disable-sse4-2)
+
+$(eval $(autotools-package))