package/lxc: add optional support for libseccomp
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 17:34:58 +0000 (18:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 20:28:55 +0000 (21:28 +0100)
When libseccomp was compiled before, lxc will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/libexec/lxc/lxc-monitord | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [liblxc.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libcap.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libseccomp.so.2]
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lxc/lxc.mk

index e382f4dec5dad28a1cfd6a98c0a047554ec01fd2..819096959a369064ada4b11549a84aa7cc6adea6 100644 (file)
@@ -15,4 +15,11 @@ LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
        --disable-lua --disable-python \
        $(if $(BR2_PACKAGE_BASH),,--disable-bash)
 
+ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
+LXC_CONF_OPTS += --enable-seccomp
+LXC_DEPENDENCIES += libseccomp
+else
+LXC_CONF_OPTS += --disable-seccomp
+endif
+
 $(eval $(autotools-package))