sdl: Fix include files install.
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 17 Mar 2008 16:39:03 +0000 (16:39 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 17 Mar 2008 16:39:03 +0000 (16:39 -0000)
Patch sdl-config rpath setting rather than setting exec-prefix and
using DESTDIR as the SDL makefile uses prefix for some files,
and exec-prefix for others leading to double $(STAGING_DIR) prefix.

package/sdl/sdl.mk

index f62889d5205fedcf0bdbdaa85b2c1f3e4ca73b2c..a11f794f947b179f0d82ab27d4cb1694380af3d0 100644 (file)
@@ -56,7 +56,6 @@ $(SDL_DIR)/.configured: $(SDL_DIR)/.unpacked
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \
                --prefix=$(STAGING_DIR)/usr \
-               --exec-prefix=/usr \
                --sysconfdir=/etc \
                --localstatedir=/var \
                --enable-pulseaudio=no \
@@ -83,9 +82,9 @@ $(SDL_DIR)/.compiled: $(SDL_DIR)/.configured $(SDL_DIRECTFB_TARGET)
        touch $@
 
 $(STAGING_DIR)/usr/lib/libSDL.so: $(SDL_DIR)/.compiled
-       $(MAKE) DESTDIR=$(STAGING_DIR) -C $(SDL_DIR) install
-# sdl-config uses -Lexec_prefix/lib instead of -Lprefix/lib - fix it
-       $(SED) 's^-L\$${exec_prefix}^-L\$${prefix}^' \
+       $(MAKE) -C $(SDL_DIR) install
+# use correct rpath for linking
+       $(SED) 's^libdir=\$${exec_prefix}^libdir=/usr^' \
                $(STAGING_DIR)/usr/bin/sdl-config
        touch -c $@