libmicrohttpd: fix build on riscv
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 10 Nov 2018 16:00:28 +0000 (17:00 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 11 Nov 2018 20:59:00 +0000 (21:59 +0100)
Define _REENTRANT like already done for ARC otherwise pthread detection
will fail

Fixes:
 - https://autobuild.buildroot.org/results/910dc7164312637bf4dcd89e4cb476ae198466c8

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libmicrohttpd/libmicrohttpd.mk

index 1cda43481994b61bf46721d811a0151132a3a30b..c22ad084788bb555bb61c05ea778728ef9cb0d48 100644 (file)
@@ -11,10 +11,10 @@ LIBMICROHTTPD_INSTALL_STAGING = YES
 LIBMICROHTTPD_CONF_OPTS = --disable-curl --disable-examples
 LIBMICROHTTPD_CFLAGS = $(TARGET_CFLAGS) -std=c99
 
-# gcc on arc doesn't define _REENTRANT when -pthread is passed while
+# gcc on arc and riscv doesn't define _REENTRANT when -pthread is passed while
 # it should. Compensate this deficiency here otherwise libmicrohttpd
 # configure script doesn't find that thread support is enabled.
-ifeq ($(BR2_arc),y)
+ifeq ($(BR2_arc)$(BR2_riscv),y)
 LIBMICROHTTPD_CFLAGS += -D_REENTRANT
 endif