package/luv: install libluv.pc.in
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 5 Sep 2019 17:07:31 +0000 (19:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Sep 2019 20:19:53 +0000 (22:19 +0200)
Archive 1.30.1-0 doesn't contain libluv.pc.in which will break the build

Fixes:
 - http://autobuild.buildroot.org/results/5ec6b5a3622c343f7e401b7da7d4a1da15be2733

This issue has been fixed upstream in
https://github.com/luvit/luv/commit/946784fba047bcd275554b5040949e3d70994b30,
which should be in the next release.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Acked-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/luv/libluv.pc.in [new file with mode: 0644]
package/luv/luv.mk

diff --git a/package/luv/libluv.pc.in b/package/luv/libluv.pc.in
new file mode 100644 (file)
index 0000000..d1544f6
--- /dev/null
@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=${prefix}
+libdir=@libdir@
+includedir=@includedir@
+
+Name: libluv
+Version: @LUV_VERSION@
+Description: Bare and full libuv bindings for Lua/LuaJIT.
+URL: https://github.com/luvit/luv
+
+Libs: -L${libdir} -lluv @LIBS@
+Cflags: -I${includedir}
index 31288ffca3e3d82691acbf31db89d8072e843693..c6a8eab15896c6210a14bf3e358b69252697ff2e 100644 (file)
@@ -11,6 +11,12 @@ LUV_LICENSE_FILES = LICENSE.txt
 LUV_DEPENDENCIES = libuv
 LUV_INSTALL_STAGING = YES
 
+# Archive 1.30.1-0 doesn't contain libluv.pc.in so install it in this hook
+define LUV_INSTALL_PC_IN
+       cp package/luv/libluv.pc.in $(@D)/
+endef
+LUV_POST_EXTRACT_HOOKS += LUV_INSTALL_PC_IN
+
 LUV_CONF_OPTS += \
        -DBUILD_MODULE=OFF \
        -DWITH_SHARED_LIBUV=ON \