uboot: unbreak legal info for legacy versions
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 25 Mar 2014 06:18:15 +0000 (07:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 25 Mar 2014 06:18:15 +0000 (07:18 +0100)
Fixes #6986

Prior to u-boot 2013.10, the GPL license text was stored in COPYING and not
Licenses/gpl-2.0.txt, breaking legal-info.

Work around it by simply copying the file from the old location to the new
if present.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/uboot/uboot.mk

index 2174584de011110fa6f9ad1ba534f3617e89f201..da67706d3110941fae116785fd1f8b45fda421f9 100644 (file)
@@ -75,6 +75,16 @@ $(if $(call qstrip,$(2)),
        @echo '#define $(strip $(1)) $(call qstrip,$(2))' >> $(@D)/include/config.h)
 endef
 
+# prior to u-boot 2013.10 the license info was in COPYING. Copy it so
+# legal-info finds it
+define UBOOT_COPY_OLD_LICENSE_FILE
+       if [ -f $(@D)/COPYING ]; then \
+               $(INSTALL) -m 0644 -D $(@D)/COPYING $(@D)/Licenses/gpl-2.0.txt; \
+       fi
+endef
+
+UBOOT_POST_EXTRACT_HOOKS += UBOOT_COPY_OLD_LICENSE_FILE
+
 ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
 define UBOOT_APPLY_CUSTOM_PATCHES
        support/scripts/apply-patches.sh $(@D) $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR) \