libgtk3: rename patches to follow the new name structure
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Tue, 11 Nov 2014 11:15:21 +0000 (11:15 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 11 Nov 2014 14:38:52 +0000 (15:38 +0100)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libgtk3/0001-no-gtk-doc.patch [new file with mode: 0644]
package/libgtk3/0002-fix-introspection-check.patch [new file with mode: 0644]
package/libgtk3/0003-disable-atk-bridge.patch [new file with mode: 0644]
package/libgtk3/0004-Fix-undefined-reference-to-get_xkb.patch [new file with mode: 0644]
package/libgtk3/0005-do-not-build-extract-strings.patch [new file with mode: 0644]
package/libgtk3/libgtk3-0001-no-gtk-doc.patch [deleted file]
package/libgtk3/libgtk3-0002-fix-introspection-check.patch [deleted file]
package/libgtk3/libgtk3-0003-disable-atk-bridge.patch [deleted file]
package/libgtk3/libgtk3-0004-Fix-undefined-reference-to-get_xkb.patch [deleted file]
package/libgtk3/libgtk3-0005-do-not-build-extract-strings.patch [deleted file]

diff --git a/package/libgtk3/0001-no-gtk-doc.patch b/package/libgtk3/0001-no-gtk-doc.patch
new file mode 100644 (file)
index 0000000..6dede73
--- /dev/null
@@ -0,0 +1,25 @@
+Same patch as for systemd in commit
+http://git.buildroot.net/buildroot/commit/?id=7144f2f04b70553
+
+Fix deactivation of gtk-doc
+
+The tarball contains the Makefile for building documentation with gtk-doc,
+Unfortunately the AM_CONDITIONAL variable is not the correct one, which
+results in an error when running autoreconf.
+
+This patch fixes this issue.
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
+
+--- a/gtk-doc.make
++++ b/gtk-doc.make
+@@ -267,7 +267,7 @@
+ #
+ # Require gtk-doc when making dist
+ #
+-if HAVE_GTK_DOC
++if ENABLE_GTK_DOC
+ dist-check-gtkdoc: docs
+ else
+ dist-check-gtkdoc:
diff --git a/package/libgtk3/0002-fix-introspection-check.patch b/package/libgtk3/0002-fix-introspection-check.patch
new file mode 100644 (file)
index 0000000..4c2806d
--- /dev/null
@@ -0,0 +1,28 @@
+Fix HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
+
+During autoreconf GOBJECT_INTROSPECTION_CHECK could not be resolved because we
+don't have introspection which provides its custom m4 macro. Reconfigure fails
+with:
+
+gdk/Makefile.am:196: error: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
+gtk/Makefile.am:1347: error: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
+
+We avoid to add a copy of introspection.m4 in the m4 directory of libgtk3 by
+adding a check, as performed in Systemd.
+
+Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -1621,7 +1621,10 @@
+ # GObject introspection
+ ##################################################
+
+-GOBJECT_INTROSPECTION_CHECK(introspection_required_version)
++m4_ifdef([GOBJECT_INTROSPECTION_CHECK],
++         [GOBJECT_INTROSPECTION_CHECK(introspection_required_version)],
++         [AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
++          enable_introspection=no])
+
+ ##################################################
+ # colord module
diff --git a/package/libgtk3/0003-disable-atk-bridge.patch b/package/libgtk3/0003-disable-atk-bridge.patch
new file mode 100644 (file)
index 0000000..c92174f
--- /dev/null
@@ -0,0 +1,45 @@
+Remove atk-bridge support.
+
+atk-bridge doesn't seem useful for now in Buildroot and requires to
+add two new packages just for it: at-spi2-core and at-spi2-atk.
+
+Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -1349,11 +1349,7 @@
+ # Check for Accessibility Toolkit flags
+ ########################################
+
+-if test x$enable_x11_backend = xyes; then
+-   ATK_PACKAGES="atk atk-bridge-2.0"
+-else
+-   ATK_PACKAGES="atk"
+-fi
++ATK_PACKAGES="atk"
+
+ PKG_CHECK_MODULES(ATK, $ATK_PACKAGES)
+
+--- a/gtk/a11y/gtkaccessibility.c
++++ b/gtk/a11y/gtkaccessibility.c
+@@ -37,10 +37,6 @@
+ #include <gtk/gtkcombobox.h>
+ #include <gtk/gtkaccessible.h>
+
+-#ifdef GDK_WINDOWING_X11
+-#include <atk-bridge.h>
+-#endif
+-
+ static gboolean gail_focus_watcher      (GSignalInvocationHint *ihint,
+                                          guint                  n_param_values,
+                                          const GValue          *param_values,
+@@ -987,9 +983,5 @@
+   _gtk_accessibility_override_atk_util ();
+   do_window_event_initialization ();
+
+-#ifdef GDK_WINDOWING_X11
+-  atk_bridge_adaptor_init (NULL, NULL);
+-#endif
+-
+   atk_misc_instance = g_object_new (GTK_TYPE_MISC_IMPL, NULL);
+ }
diff --git a/package/libgtk3/0004-Fix-undefined-reference-to-get_xkb.patch b/package/libgtk3/0004-Fix-undefined-reference-to-get_xkb.patch
new file mode 100644 (file)
index 0000000..c2f4b4f
--- /dev/null
@@ -0,0 +1,33 @@
+From b64a04250b1f35923434158beb6ddb5726b41eac Mon Sep 17 00:00:00 2001
+From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Date: Mon, 27 Oct 2014 10:34:38 +0100
+Subject: [PATCH 1/1] Fix undefined reference to get_xkb()
+
+When configuring Gtk+ with --disable-xkb, the build fails because of an
+undefined reference to get_xkb().
+
+This patch fixes this issue.
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+---
+ gdk/x11/gdkkeys-x11.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/gdk/x11/gdkkeys-x11.c b/gdk/x11/gdkkeys-x11.c
+index c45a971..6a5481b 100644
+--- a/gdk/x11/gdkkeys-x11.c
++++ b/gdk/x11/gdkkeys-x11.c
+@@ -1498,8 +1498,10 @@ gdk_x11_keymap_map_virtual_modifiers (GdkKeymap       *keymap,
+   int i, j;
+   gboolean retval;
++#ifdef HAVE_XKB
+   if (KEYMAP_USE_XKB (keymap))
+     get_xkb (keymap_x11);
++#endif
+   retval = TRUE;
+-- 
+1.9.1
+
diff --git a/package/libgtk3/0005-do-not-build-extract-strings.patch b/package/libgtk3/0005-do-not-build-extract-strings.patch
new file mode 100644 (file)
index 0000000..f1fbaaa
--- /dev/null
@@ -0,0 +1,47 @@
+Do not build util/extract-strings
+
+Do not build util/extract-strings, as it will be built by host-libgtk3
+and installed in $(HOST_DIR)/usr/bin (thus avoiding the -lint linking
+issue with uClibc).
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+
+Index: gtk+-3.14.0/Makefile.am
+===================================================================
+--- gtk+-3.14.0.orig/Makefile.am       2014-09-22 05:17:44.000000000 +0200
++++ gtk+-3.14.0/Makefile.am    2014-09-25 16:08:32.000000000 +0200
+@@ -1,7 +1,7 @@
+ ## Makefile.am for GTK+
+ include $(top_srcdir)/Makefile.decl
+-SRC_SUBDIRS = util gdk gtk libgail-util modules demos tests testsuite examples
++SRC_SUBDIRS = gdk gtk libgail-util modules demos tests testsuite examples
+ SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros build
+ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+Index: gtk+-3.14.0/gtk/Makefile.am
+===================================================================
+--- gtk+-3.14.0.orig/gtk/Makefile.am   2014-09-22 05:09:39.000000000 +0200
++++ gtk+-3.14.0/gtk/Makefile.am        2014-09-25 16:09:10.000000000 +0200
+@@ -1330,7 +1330,7 @@
+ %.ui.h: %.ui
+       $(AM_V_GEN) mkdir -p $(dir $@) \
+-      && $(top_builddir)/util/extract-strings$(EXEEXT) $< > $@
++      && extract-strings$(EXEEXT) $< > $@
+ #
+ # rules to generate built sources
+Index: gtk+-3.14.0/gtk/inspector/Makefile.am
+===================================================================
+--- gtk+-3.14.0.orig/gtk/inspector/Makefile.am 2014-09-04 20:11:33.000000000 +0200
++++ gtk+-3.14.0/gtk/inspector/Makefile.am      2014-09-25 16:09:48.000000000 +0200
+@@ -114,7 +114,7 @@
+ template_headers = $(templates:.ui=.ui.h)
+ %.ui.h : %.ui 
+-      $(AM_V_GEN) $(top_builddir)/util/extract-strings$(EXEEXT) $< > $@
++      $(AM_V_GEN) extract-strings$(EXEEXT) $< > $@
+ EXTRA_DIST +=                                 \
+       inspector.gresource.xml         \
diff --git a/package/libgtk3/libgtk3-0001-no-gtk-doc.patch b/package/libgtk3/libgtk3-0001-no-gtk-doc.patch
deleted file mode 100644 (file)
index 6dede73..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-Same patch as for systemd in commit
-http://git.buildroot.net/buildroot/commit/?id=7144f2f04b70553
-
-Fix deactivation of gtk-doc
-
-The tarball contains the Makefile for building documentation with gtk-doc,
-Unfortunately the AM_CONDITIONAL variable is not the correct one, which
-results in an error when running autoreconf.
-
-This patch fixes this issue.
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
-
---- a/gtk-doc.make
-+++ b/gtk-doc.make
-@@ -267,7 +267,7 @@
- #
- # Require gtk-doc when making dist
- #
--if HAVE_GTK_DOC
-+if ENABLE_GTK_DOC
- dist-check-gtkdoc: docs
- else
- dist-check-gtkdoc:
diff --git a/package/libgtk3/libgtk3-0002-fix-introspection-check.patch b/package/libgtk3/libgtk3-0002-fix-introspection-check.patch
deleted file mode 100644 (file)
index 4c2806d..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-Fix HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
-
-During autoreconf GOBJECT_INTROSPECTION_CHECK could not be resolved because we
-don't have introspection which provides its custom m4 macro. Reconfigure fails
-with:
-
-gdk/Makefile.am:196: error: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
-gtk/Makefile.am:1347: error: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
-
-We avoid to add a copy of introspection.m4 in the m4 directory of libgtk3 by
-adding a check, as performed in Systemd.
-
-Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1621,7 +1621,10 @@
- # GObject introspection
- ##################################################
-
--GOBJECT_INTROSPECTION_CHECK(introspection_required_version)
-+m4_ifdef([GOBJECT_INTROSPECTION_CHECK],
-+         [GOBJECT_INTROSPECTION_CHECK(introspection_required_version)],
-+         [AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
-+          enable_introspection=no])
-
- ##################################################
- # colord module
diff --git a/package/libgtk3/libgtk3-0003-disable-atk-bridge.patch b/package/libgtk3/libgtk3-0003-disable-atk-bridge.patch
deleted file mode 100644 (file)
index c92174f..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-Remove atk-bridge support.
-
-atk-bridge doesn't seem useful for now in Buildroot and requires to
-add two new packages just for it: at-spi2-core and at-spi2-atk.
-
-Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1349,11 +1349,7 @@
- # Check for Accessibility Toolkit flags
- ########################################
-
--if test x$enable_x11_backend = xyes; then
--   ATK_PACKAGES="atk atk-bridge-2.0"
--else
--   ATK_PACKAGES="atk"
--fi
-+ATK_PACKAGES="atk"
-
- PKG_CHECK_MODULES(ATK, $ATK_PACKAGES)
-
---- a/gtk/a11y/gtkaccessibility.c
-+++ b/gtk/a11y/gtkaccessibility.c
-@@ -37,10 +37,6 @@
- #include <gtk/gtkcombobox.h>
- #include <gtk/gtkaccessible.h>
-
--#ifdef GDK_WINDOWING_X11
--#include <atk-bridge.h>
--#endif
--
- static gboolean gail_focus_watcher      (GSignalInvocationHint *ihint,
-                                          guint                  n_param_values,
-                                          const GValue          *param_values,
-@@ -987,9 +983,5 @@
-   _gtk_accessibility_override_atk_util ();
-   do_window_event_initialization ();
-
--#ifdef GDK_WINDOWING_X11
--  atk_bridge_adaptor_init (NULL, NULL);
--#endif
--
-   atk_misc_instance = g_object_new (GTK_TYPE_MISC_IMPL, NULL);
- }
diff --git a/package/libgtk3/libgtk3-0004-Fix-undefined-reference-to-get_xkb.patch b/package/libgtk3/libgtk3-0004-Fix-undefined-reference-to-get_xkb.patch
deleted file mode 100644 (file)
index c2f4b4f..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From b64a04250b1f35923434158beb6ddb5726b41eac Mon Sep 17 00:00:00 2001
-From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-Date: Mon, 27 Oct 2014 10:34:38 +0100
-Subject: [PATCH 1/1] Fix undefined reference to get_xkb()
-
-When configuring Gtk+ with --disable-xkb, the build fails because of an
-undefined reference to get_xkb().
-
-This patch fixes this issue.
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
----
- gdk/x11/gdkkeys-x11.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/gdk/x11/gdkkeys-x11.c b/gdk/x11/gdkkeys-x11.c
-index c45a971..6a5481b 100644
---- a/gdk/x11/gdkkeys-x11.c
-+++ b/gdk/x11/gdkkeys-x11.c
-@@ -1498,8 +1498,10 @@ gdk_x11_keymap_map_virtual_modifiers (GdkKeymap       *keymap,
-   int i, j;
-   gboolean retval;
-+#ifdef HAVE_XKB
-   if (KEYMAP_USE_XKB (keymap))
-     get_xkb (keymap_x11);
-+#endif
-   retval = TRUE;
--- 
-1.9.1
-
diff --git a/package/libgtk3/libgtk3-0005-do-not-build-extract-strings.patch b/package/libgtk3/libgtk3-0005-do-not-build-extract-strings.patch
deleted file mode 100644 (file)
index f1fbaaa..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-Do not build util/extract-strings
-
-Do not build util/extract-strings, as it will be built by host-libgtk3
-and installed in $(HOST_DIR)/usr/bin (thus avoiding the -lint linking
-issue with uClibc).
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-
-Index: gtk+-3.14.0/Makefile.am
-===================================================================
---- gtk+-3.14.0.orig/Makefile.am       2014-09-22 05:17:44.000000000 +0200
-+++ gtk+-3.14.0/Makefile.am    2014-09-25 16:08:32.000000000 +0200
-@@ -1,7 +1,7 @@
- ## Makefile.am for GTK+
- include $(top_srcdir)/Makefile.decl
--SRC_SUBDIRS = util gdk gtk libgail-util modules demos tests testsuite examples
-+SRC_SUBDIRS = gdk gtk libgail-util modules demos tests testsuite examples
- SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros build
- ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-Index: gtk+-3.14.0/gtk/Makefile.am
-===================================================================
---- gtk+-3.14.0.orig/gtk/Makefile.am   2014-09-22 05:09:39.000000000 +0200
-+++ gtk+-3.14.0/gtk/Makefile.am        2014-09-25 16:09:10.000000000 +0200
-@@ -1330,7 +1330,7 @@
- %.ui.h: %.ui
-       $(AM_V_GEN) mkdir -p $(dir $@) \
--      && $(top_builddir)/util/extract-strings$(EXEEXT) $< > $@
-+      && extract-strings$(EXEEXT) $< > $@
- #
- # rules to generate built sources
-Index: gtk+-3.14.0/gtk/inspector/Makefile.am
-===================================================================
---- gtk+-3.14.0.orig/gtk/inspector/Makefile.am 2014-09-04 20:11:33.000000000 +0200
-+++ gtk+-3.14.0/gtk/inspector/Makefile.am      2014-09-25 16:09:48.000000000 +0200
-@@ -114,7 +114,7 @@
- template_headers = $(templates:.ui=.ui.h)
- %.ui.h : %.ui 
--      $(AM_V_GEN) $(top_builddir)/util/extract-strings$(EXEEXT) $< > $@
-+      $(AM_V_GEN) extract-strings$(EXEEXT) $< > $@
- EXTRA_DIST +=                                 \
-       inspector.gresource.xml         \